Firefox - No (or Extremely-Limited) Internet Access

> I’d just installed Opera, and maybe a Windows program using Wine.

was it a browser related program you installed with WINE?

maybe the window’s installer poisoned a well it should not have been
able to touch/change…

were you logged into KDE as root, or running WINE from a root powered
terminal?


palladium

I added KWrite to the list, then specified KWrite to open it, and it opened okay. But when I just left click profile.int, it still wants to execute Wine.

Thanks for the suggestions, Palladium – will give them a try.

The program was not browser related. I was not running Wine from a terminal, nor was I logged in at the root level.

Notepad is a M$ app.

This profile.int
Do you mean profile.ini
in FF profile folder?

We already tried deleting the whole .mozilla profile, so it ain’t related to that.
Are you sure you haven’t be using winetricks?

I want you to try creating a New User
Yast - Security and Users - User Group Management

Logout and in with the new user and see how FF is

Very good, caf – am at work now, so will try to work on this when time allows…

adreampuppet wrote:
> Ok – the default is already set as Notepad. Yet it tries to open with
> Wine…?

Notepad is a Windows program, right?
it should not be the default for anything you do in Linux (in my
opinion, if not a technical/security problem)


palladium

adreampuppet wrote:
> But when I just left click profile.int, it still wants to
> execute Wine.

this is not Windows, do NOT left click on icons in the menu or in a
file manager unless you WANT to run it…instead, RIGHT click on it
and pick from the menu what you want to do, like “Open” with Kwrite,
or whatever…

it is beginning to sound like WINE has ‘told’ Linux that files named
*.int should be opened with WINE…


palladium

caf: FF works properly under a new user.

Backup your files to dvd or pen drive, whatever, but only what you need. None of that mess you seem to have made.
Log in to the new user
Then transfer it to the new user and remove the old profile properly via Yast - Security and Users - User Group Management

None of that mess you seem to have made.

LOL! I read this while gazing at your icon – perfect!

I will do as you suggest, and get a new start.

Thanks to you both for all your time and assistance…

Good luck friend:)

I believe I may be having the same problem as the OP, but I don’t want to use the same solution. I’d much rather figure out what’s going on with Firefox.

First, I’d like to state that Wine is not the culprit. Here’s what’s happening in a nutshell: my “homepage” has become the root URL of everything. For example, my homepage is set to Google and when I want to go to http://www.opensuse.org I am taken to http://www.google.com instead. If however, I wanted to go to

http://forums.opensuse.org/network-internet/425828-firefox-no-extremely-limited-internet-access.html

I get this

http://forums.google.com/network-internet/425828-firefox-no-extremely-limited-internet-access.html

When I change my homepage and restart firefox I get similar results but with a new “base URL” based on my new homepage. The entire domain portion of the URL just gets swapped out. It’s the craziest ****ed thing and it’s driving me nuts. If anyone knows what could be doing this, I’d love to hear your ideas. I’d also like (if possible) for the OP to confirm if this is the problem he was experiencing.

EDIT: I should probably state that the URL in the location bar still reads the correct URL even though the page that is served is from whatever server my homepage is set to. I can provide screenshots if necessary.

Ok, I managed to resolve my problems with Firefox by disabling the default proxy settings.

Preferences > Advanced > Network(tab)

Click “Settings” to configure how Firefox connects to the internet. The default selection is “Use system proxy settings” so I changed it to “No proxy.” I no longer have any problems with Firefox using the homepage as a base URL.

All that said, I still don’t understand what the real problem is. It worked fine with the default setting for a few days since installing 11.2.

It worked fine with the default setting
Proxy is not default!

Just to be clear, there is no proxy. The default selection, “Use system proxy settings” just means to follow system defaults. That way, if I setup a system wide proxy setting Firefox should use them. By selecting “No proxy,” I am actually forcing Firefox to override any system proxy settings.

Firefox should work fine with the system proxy settings selected. I hope to find out why it didn’t. I imagine that I (and maybe the OP) goofed something up somehow.

I have been having the same problem that the last part of the posting refers to. I did a fresh install of 11.2, formatting over an old 11.1 / partition. Using my old /home directory and the corresponding account Firefox displays the bad proxy behaviour and I can’t seem to get any other sites. I deleted the mozilla profile and Firefox does the same thing, except the bad proxy now seems to be mozilla.org instead of opensuse.org. I created a new account and Firefox behaves properly, so it doesn’t seem to be a system wide preference setting.

Could this have something to do with user id # maybe? I had changed that on my old account.

CranKey, can you check your Firefox proxy settings in your new account and tell us what it defaults to?

Both the ‘new’ and the ‘existing’ accounts have the same settings in Firefox. They are both set to use the system defaults for proxy. Here I should clarify some things.

The new account is new to 11.2, because I created it on an earlier install of 11.2 but then subsequently reinstalled. So the ‘new’ account wasn’t around when I was running 11.1 .

The existing account FF setup is new in that I had deleted the contents of the .mozilla/firefox directory in an attempt to clear this problem so what is in that directory now was created by FF the next time I started it. The behavior remained the same except that the proxy changed from opensuse.org to mozilla.org which seems to indicate that it’s using the home page setting as its proxy. (The homepage from the suse install was opensuse.org and the homepage created by FF is mozilla.com or something like that.)

With the old account I changed the homepage from opensuse.org to google.com and tried to access google but it didn’t work. However, after restarting FF google came up as the home page but no other urls would work, including opensuse.org.

So for some reason upon starting FF seems to be taking its homepage setting as the proxy and sticking with that.

Any suggestions to determine the problem? I don’t want to just make a new account because that won’t fix the bug.

Thanks

Just an update.

Setting Firefox to ‘no proxy’ seems to fix the problem. However, the last time I tried starting FF I got the bouncing FF icon for a little while then it just went away without starting. Clicking the icon a second time seemed to start it.

Also, after I got it working with the ‘no proxy’ setting I tried changing it back but the problem returned. I thought I would try that just to see if it was some kind of initialization issue.

One other note. I’ve set up the packman repos and have the system using those when possible. I don’t know if that would make a difference, but I thought I’d mention it just to be complete. (I can’t recall if FF is included in the packman repos)

FF is not in Packman
But using Packman First is for Multi-Media
Bouncing Cursor is known issue