Firefox Mplayer plugin

Does anyone know how to play .wmv files in Firefox 4 on opensuse 11.4? Mplayerplug-in is not available in the Packman repository. I would really like to use the vlc plugin, but it stop working for me several years ago and several releases ago.

You will find mmcheck in the openSUSE factory area of the search engine: Search Results

simply install it as per this guide:
MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps

if you install the apps as noted in mmcheck script (aside from mplayerplug-in) you should be able to install this.

You could also rebuild mplayerplug-in from an older openSUSE version src rpm file, but to do that typically requires long-in-the-tooth-average or advanced knowledge.

gecko-mediaplayer is what you require, but it has not been built for 11.4 in Packman repo yet.

It is here:
Index of /repositories/home:/RedDwarf/openSUSE_11.4

Firefox 4 on opensuse 11.4?

FireFox4 TESTING only BETA – ok
OpenSUSE 11.4 RC2 TESTING only - ok

well if you do not already KNOW how to fix this then why are you using two TESTING ONLY versions

Build the programs on 11.4 rc2 and for ff4 and add back to the community .

Many Thanks caf4926 that did the trick.
Just curious as to why there does not seem to anything about getting the media player in Firefox working. I have been Googleing for days to try to find out how to get this thing to work. One sidebar, had to select x11 video out in the preferences to get the plugin to display. Anyway thanks again for your help, problem solved.

I nudged the Packman team too and it 's in packman now too.
It might be wise to drop RedDwarf if favour of Packman, if only to keep your repos to a minimum. Though RedDwarf has a reputation for keeping it very up to date.

To be honest, Firefox just works for me after I do my multi-media install, that includes gecko-mediaplayer once it’s available and it is mentioned in the multimedia guide.

IMHO the best thing to do (before spending days) is what you just did, which is to post on a forum asking for help. I know its nice to be able to solve things one’s self, but in terms of efficiency I find it quicker after a reasonably short surf (on google) to ask for help if no luck on google. I post at times on our forum asking for advise as well.

Glad to read this is working now.

Thanks to all for your help and suggestions. caf4926, which “multimedia guide” are you referring to?

Multi-media and Restricted Format Installation Guide

it is now: Index of /repositories/home:/RedDwarf/openSUSE_11.4

Yes we know

click wmv file on your desktop with right mouse button and choose properties-> open with -> mplayer. after that try again playing the file with your browser

MPlayer-Plugin hasn’t been updated in 3 years - switch to using gecko-mediaplayer (mplayer) or xine-browser-plugin (xine) instead.

I still can’t find the mplayerplug-in for 11.4 on packman ?

use gecko-mediaplayer

Correct, it’s not built (anymore??)

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 22:16, 3 users, load average: 0.23, 0.11, 0.13
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

Well I tried gecko- mediaplayer and now I get a black media screen trying this;

The Pigeon: Impossible Podcast

solved I had to choose video output xv in the gnome media player.

I’ve been wondering about Mplayerplug-in for a while. I’m glad I came across this thread!

On Fri, 12 Aug 2011 13:46:03 +0000, anton wrote:

> Well I tried gecko- mediaplayer and now I get a black media screen
> trying this;
> ‘The Pigeon: Impossible Podcast’
> (

Me too.

Also, the menu which is supposed to be at the bottom of the frame is
missing but appears instead across the Pan display (of your post and part
of mine)! This bleed has been happening where the background colour is
black but it’s the first time I’ve seen it in a white background. I think
it’s time to back out of nVidia driver and crawl back to nouveau. Drat!

Graham Davis, Bracknell, Berks.
openSUSE 11.4; KDE 4.7.0; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210; Sound: ATI SBx00 Azalia (Intel HDA);
Wireless: BCM4306