Firefox middle button scroll not working as it should

Hi I registered here because I have an issue that is buggering me quite well.

I installed 13.2 with XFCE desktop. I’ve tried both the netinstall iso and the dvd iso and get the same result.
I have a Thinkpad Txxx laptop and it has three buttons. I always use the middle button pressed to scroll.
And there mostly appears a round icon with an up arrow, dot and down arrow. (See picture below)
However I can not get this to work in suse!

If I disable the paste function in about:config and other things that often overtake the functionality and enable autoscroll I have “once” gotten this to work. But after I close firefox and reopen it the function is gone and the normal scroll is back.

The normal middle button scroll means that it does scroll BUT the mouse cursor is trapped in its position until the button is let off. And this is not what I want because it makes the trackpoint hard to use. (The little red dot on thinkpad keyboards).

This issue appears both in the Firefox version in the dvd iso and the 38.0.1 update after installing all the updates from suse repository.

I hope some friendly soul can help me with this.

The icon on the right is what I want to appear, just like it does in arch or gentoo.

https://infotomb.com/guytz.png

Edit:
Oh and to mention. When I reopen firefox and the arrow is gone. The settings has not changed.
Autoscroll is still enabled. And it does not make any difference to switch it off and back on again. The result remain the same.

I’m whole guessing that you are using a pad and not a real mouse???

I do have a Logitech mx518 mouse that I switch to and from, depending if I’m working at a table or not.
I primary use the “trackpoint” pointing stick on my keyboard because Im on a laptop. (The red dot in the middle of the keyboard)
I never use the touchpad.

https://infotomb.com/nhvkv.jpg

Arrows in the picture shows
RED: Trackpoint
BLUE: Middle button keyboard

This issue appears regardless if Im using the mouse or the trackpoint alone.
Clicking the scroll wheel on my logitech mouse does the same thing as clicking the middle button on the keyboard. It locks the cursor into place until I let go of the key.


I need to mention and clarify. There are two scenarios. Scroll functionality works in either of the scenarios. But they differs in how they function.

1.
**1a)
**If I press and let go of the key.
This scroll icon appears and I can scroll up or down by moving the mouse. In addition to the scroll icon I get a normal cursor or an I-beam cursor that I can move around freely.
http://cdn3.howtogeek.com/wp-content/uploads/2008/03/270x238ximage136.png.pagespeed.ic.otxzs_VmdR.png

1b) I press middle button again to exit scroll icon and cursor is back.

2.
2a)

If I press and hold on to the key.
The cursor icon locks into place and I can scroll up or down by moving the mouse.
https://infotomb.com/wltot.gif

2b)
If I let go of the middle button the locked cursor exit scroll mode and I can freely move the cursor again.
https://infotomb.com/fp8u3.gif

**Scenario 2 **is what Is causing problems.
It should behave scenario 1 but functions when I “click and hold” middle button because I modified the settings by activating “Use autoscrolling” in firefox. And disabling “Middle.button.paste” in about:config.
BUT this only works for a while. For example if I close firefox and re-open firefox. Then scroll functionality moves back to scenario 2 regardless if “Use autoscrolling” is still checked.

I’m starting to wonder if this is a bug in opensuse. It might have something to do with one or some of the Opensuse branding options that you can either check or uncheck during install. But unchecking one of the many options caused many disputes with dependencies being broken.
Grrrr this is grinding my gears.

of topic:
I also have a bug that firefox freezes if draging the tab bar causing the window to exit maximized mode when having the htitle extension installed, same result with hide caption titlebar plus.

https://addons.mozilla.org/sv-se/firefox/addon/htitle/
https://addons.mozilla.org/en-US/firefox/addon/hide-caption-titlebar-plus-sma/

Never has worked that way here ever, but then I don’t have a notebook. and I only use a real mouse. Apparently it is some feature of the mouse pad software at least in the past??? Maybe you need to investigate other mouse pad drivers that maybe have that feature.

**Scenario 2 **is what Is causing problems.
It should behave scenario 1 but functions when I “click and hold” middle button because I modified the settings by activating “Use autoscrolling” in firefox. And disabling “Middle.button.paste” in about:config.
BUT this only works for a while. For example if I close firefox and re-open firefox. Then scroll functionality moves back to scenario 2 regardless if “Use autoscrolling” is still checked.

I’m starting to wonder if this is a bug in opensuse. It might have something to do with one or some of the Opensuse branding options that you can either check or uncheck during install. But unchecking one of the many options caused many disputes with dependencies being broken.
Grrrr this is grinding my gears.

You mentioned that Firefox behaves as expected with Arch of Gentoo. Could be related to FF version perhaps?

I have really no idea at this point.
I downloaded the firefox-38.0.5.tar.bz2 from mozilla’s server and executed the program and got the same result. Both with the mouse scroll function and Firefox freezing with htitle add-on.
However I’m not sure that Firefox where executed completely isolated. It might have opened the existing profile from the already installed Firefox.

I will make another try later today and install Opensuse without Firefox and Thunderbird checked at install to get a clean base. And then download the latest tar.bz2 from Mozilla.
I will try to find out how to get a debug log from Firefox and system to perhaps help pinpoint what is going wrong.

I was really asking what version of FF are your Arch and Gentoo installs using?

BTW, the RPM package available from the Mozilla repo is no different to the tarball package you installed.

I cant quite remember. Hold on and I will check. I’ll be back later.

Firefox version used in distros.

Arch
Firefox 38.0.1-1
Repository: Local

Gentoo
Firefox 38.0.1~0
Repository: Mirrored, Netherlands

Opensuse
Firefox 38.0.1-30-1
Repository: Opensuse

I installed Opensuse 13.2 XFCE again.
I unchecked many things during install including all Mozilla programs.
Laptop patterns, synaptic driver.

After the install finished and I searched Firefox in yast add/remove software I cannot install Firefox without yast forcing to install Opensuse branding packages.
So I downloaded firefox-38.0.5.tar.bz2 from mozilla’s ftp server and tried it. I get the exact same result. But with one difference now.
When I activate “Use autoscrolling” it does not work at all. Before I installed Opensuse, same .iso file last week I got the function to work for a little while until I closed firefox. But this time nothing happens. Scroll functions still behaves as** scenario 2**.

At this moment I’m writing this post on Gentoo. I removed Firefox 38.0.1~0 and unpacked the same firefox-38.0.5.tar.bz2 I tried in Opensuse. And “Use autoscrolling” works just as it should. No problems.

I just discovered something.

I reinstalled Opensuse with LXDE with the same result.
But I reinstalled once again with KDE Plasma and this time I scroll function operates different.

When pressing middle button on the keyboard it acts the same way as Scenario 2. But when I plugged in the mouse I could without any issues press and hold the middle button and scroll just like it should in scenario 1.
So there might be something about synaptic in Opensuse that causes this issue.

I qoute your post as you had a small point that helped me to pinpoint the issue.

I can say that I have solved the issue now. At least with the “Use autoscrolling” feature not working with trackpoint device.

The file located in /etc/X11/xorg.conf.d/11-evdev.conf contains the following information

Section "InputClass"
        # Novell Bugs #597214, #780626, #843333, #861813
    Identifier      "Trackpoint Wheel Emulation"
    MatchProduct    "TPPS/2 IBM TrackPoint|ThinkPad USB Keyboard with TrackPoint"
        MatchIsPointer  "off"
        Driver  "evdev"
        Option  "EmulateWheel"  "on"
        Option  "EmulateWheelButton"    "2"
        # Since middle button is in use now these button events need to be emulated (bnc#869097)
        Option  "Emulate3Buttons" "on"
EndSection

This is the source of my issue. I moved the file into a new folder that I named “backup” and rebooted. Causing the file not to be initiated at boot.
The issue is now gone. I can scroll just as well with my Logitech mouse as with my Trackpoint device on my Thinkpad keyboard. It behaves just as scenario 1 but when I “push and hold” the middle button.

Well done with tracking the cause of the behaviour to the evdev configuration file. Ironically, that file was actually added as a result of the following bug reports

 # Novell Bugs #597214, #780626, #843333

The last is especially relevant
https://bugzilla.novell.com/show_bug.cgi?id=843333
but perhaps it doesn’t cover the behaviour of all “TPPS/2 IBM TrackPoint” devices as intended. As with most things these files can be edited to suit as required.

Thank you. Its been a long weekend.
After some sleep I reinstalled everything again with XFS encryped and XFCE. And I got vmware workstation up and running. So all good!
Opensuse really fit my laptop and style of workspace as is has yast that acts as a central managment that ease the fact that I’m on a laptop = small screen and limited workspace quickly make things cluttered and frustrating to find the right tool.