Firefox - Many embedded URLS in emails will not connect, produce Error 504 timeout

I am running Firefox 116.0.3 from the Mozilla Repo
My system runs Plasma5/QT 5 from the Frameworks5 repo
I find that when clicking embedded URLs in email messages with Firefox set as the default browser, the connection times out with error. If I copy then paste-and-go into Chrome on the same system, the URL opens normally.

Any similar experience out there?

Sorry, error in the Subject, I typically get a 504 Gateway Timeout, not 404

Changed it in the title.

1 Like

What happens if you copy (in MUA) and paste into already running Firefox?

Ahh, good question.
I tried, get same Failure both on an auto-open new tab or a tab that I open first, then copy-and-go.

This seems to be variable depending on the origin of the URL. One I use a lot is a Post office daily message that lists arriving packages, with clickable URLs for deeper information.

I should also add that I see this on Firefox/Plasma5. I do not see this on Firefox/Windows 10

So your problem could be related to the link you are trying to open.

But it could be related to the EMail-client you are using as well.

On my system I can click on links in EMails and they will open in the browser.

My system:

Operating System: openSUSE Tumbleweed 20230822
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 6.4.11-1-default (64-bit)
Graphics Platform: X11
Graphics Processor: Mesa Intel® HD Graphics 630

Email-Client (MUA): Thunderbird 102.14.0
Browser: Firefox 116.0.3

Repositories in use: Only Tumbleweed + Packman

It could be useful to get more details about your system.

If you have some extensions (ad blocker, Malwarebytes, …) running in Firefox try disabling them temporarily to see if that makes a difference.

Here is my info:

Operating System: openSUSE Leap 15.5
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 5.14.21-150500.55.19-default (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 3600X 6-Core Processor
Memory: 31.2 GiB of RAM
Graphics Processor: AMD CEDAR

The only add-in I have running in Firefox is a password manager, I have tried with it disabled and it does not make a difference.

Thank you both for ideas.

This issue existed with 15.4 on the same machine, I am finally getting to try and debug.
So a difference between my system and susejuky’s is Intel vs AMD.
I have been using the Frameworks5 Repos for many years now, sometimes with mixed results due to
installed packages being inconsistent(not following the higher priority of Frameworks and QT5 repos).
I am considering just moving to TW like susejunky has to see if that makes life simpler.