Firefox layout problem, version 4.0b

I just installed suse 11.4 stable.

In the older version of firefox the tabs are right above the browser window. In this version there in the wrong place. It’s counter-intuitive to not have it right above the browser window. How do put it back? Else, how do install the older firefox. Thanks.

Deselect Tabs on Top in Preferences.

That problem, I solved quickly enough. Perhaps I solved it by accident. I think the bookmark toolbar was turned on. So when I went to turn that off, I saw the “tabs on top” setting and turned that off.

I still am looking to the left of the screen for the page refresh and home page buttons. But I guess I will eventually get used to their new locations.

It was worse when I tried firefox 4 in Windows. The menu bar was turned of, so it wasn’t clear how to get to settings to turn that back on. It turned out that there was a “firefox” button that could be used to access settings, enabling toolbars, etc.

I am getting used to the new firefox. It has a nice feel to it. Now if somebody would fix the “openSuSE firefox extensions” add-on, things would really be great.

The one significant problem that I have noticed: with firefox 3.6.x the private browsing mode kept flash cookies private. With the beta firefox 4, that is no longer true; private browsing still allows access to saved flash cookies, and can save flash cookies to be accessed from outside of private browsing mode.

Use the addon - betterprivacy. It the best i’v seen for dealing with flash cookies. I have it setup clear all cookies on closing firefox. It has lots of settings you can choose from.

Thanks, it looks much better now.