Firefox is getting on my nerves

The problem.

When I watch a playlist on you tube, every freaking time it start a new vid, the volume increases.

I am starting to get the feeling to kill a programmer. Why can’t Fire Fox leave my system volume alone ? >:(

I remember from the past having the opposite problem, but hoping somebody knows a solution ?

I am totally annoyed, who ever thought it was a good idea to keep resetting audio volume ? I don’t get it.

Do I need to file a bug report at Mozilla ?
After googling I found out, I don’t seem to be the only one have having this issue, I see even windows users complaining about this, but no solutions :frowning:

Not sure of this is related ?

I am starting to become convinced, this is 100% a Firefox problem, nothing to do with openSUSE.

While reading the replies on the bugzilla, I saw a name I know. One of the Ardour developers.
Its a small Linux world.

One thing I know for sure, he is not using openSUSE.

Going off topic,
For those wondering Ardour? :

In stalling and using Jack might fix this issue, I would need to test that. (feels weird with pipe wire on its way though)

Paul davis wrote:

edited /etc/pulse/daemon.conf to set flat-volumes to no. ran pulseaudio -k (which stops and restarts pulse). visited a youtube video, played with volume. Pulse playback volume is modified by HTML5 video volume control.

edited /etc/pulse/daemon.conf to set flat-volumes to yes ran pulseaudio -k (which stops and restarts pulse). visited a youtube video, played with volume. Pulse playback volume is modified by HTML5 video volume control.

I do not have ~/.pulse or ~/.config/pulse/*.config

in short: I can’t see any difference arising from this setting, even though I agree that from its description it ought to work.


Some stuff to think about and or try. :slight_smile:

TW is already using pipewire.
Check for presence of pipewire-pulseaudio package and other pipewire settings.
You may try to uninstall pipewire and use PulseAudio instead.

guus@localhost:~> pactl info 
Server tekenreeks: /run/user/1000/pulse/native 
Bibliotheek protocolversie: 35 
Server protocolversie: 35 
Is Local: ja 
Cliënt-index: 186 
Tegelgrootte: 65472 
Gebruikersnaam: guus 
Hostnaam: localhost.localdomain 
Servernaam: pulseaudio 
Serverversie: 15.0 
Standaard-bemonsteringsspecificatie: s16le 2ch 44100Hz 
Standaard-kanalenkaart: front-left,front-right 
Standaardafvoer: alsa_output.pci-0000_09_00.3.analog-stereo 
Standaardbron: alsa_input.pci-0000_09_00.3.analog-stereo 
Cookie:  917a:68cd

Unless I am mistaken, I am not using pipewire yet. :slight_smile:
I do know some parts of pipewire are already installed.

Better use LANG=C before any commands you want to post in the English language section. LIke

LANG=C pactl info

I installed wire plumber, then YAST wanted to uninstall Pulse, and I accepted:

uus@localhost:~> LANG=C pactl info 
Server String: /run/user/1000/pulse/native 
Library Protocol Version: 35 
Server Protocol Version: 35 
Is Local: yes 
Client Index: 88 
Tile Size: 65472 
User Name: guus 
Host Name: localhost.localdomain 
S**erver Name: PulseAudio (on PipeWire 0.3.51)** 
Server Version: 15.0.0 
Default Sample Specification: float32le 2ch 48000Hz 
Default Channel Map: front-left,front-right 
Default Sink: alsa_output.pci-0000_09_00.3.analog-stereo 
Default Source: alsa_input.pci-0000_09_00.3.analog-stereo 
Cookie: e244:00dc

For now I still have sound and all seems fine. Not sure if this fixes the firefox issue but we will see.