Firefox in openSUSE 11.4 fonts looked squished


I am running openSUSE 11.4 GNOME and does anyone has a problem with FF’s fonts? When I start up FF, the URL bar’s fonts looked squished and part of the web page’s rendered fonts, especially towards middle of the screen also look squished.

I have to minimise then restore FF to correct it.

This happens to all my notebooks I have tried, Lenovo Z360, HP Mini 2140 and Compaq nc2400; all using Intel 915 with the exception of my Lenovo Z360 which also comes with a NVIDIA 310M chip.

I have tried disabling Compiz and even removed it but did not solve the issue. I also left the fonts as Sans, and also tried setting it to Verdana or Deja Vu or Droid.

Any idea? While I may be able to live with it, it is kinda embarrassing to be touting openSUSE 11.4 if something that should work like FF mucks up the noob experience. Chromium and Opera doesn’t seem to suffer this issue with fonts.

I will appreciate any help. Many Thanks.


I had a similar issue, it appears not to load to full screen properly at initial launch. Disabling desktop effects resolved this problem for me. This is a ‘workaround’ not a solution, but I have had a number of difficulties caused by desktop effects.
Anyway. all I know is it is something to do with that, but I dont have enough time to investigate further.

I have actually remove the darn Compiz and it is still the same. Fracking annoying.