firefox: how to get rid of black popups

Hi, how to get rid of this black popups when I hoover the mouse on??
https://susepaste.org/view//40146566https://susepaste.org/view//40146566

Technically, I don’t think that’s considered a popup. It is usually called a “mouse-over” or a “tool-tip”.

I don’t know if there is a firefox setting to disable them. Just be careful where you move your mouse.

Looks like you use some color scheme that doesn’t work OK with GTK apps. In the past I’ve seen the same in GIMP.

If that’s what you really want …

Go to about:config and toggle “browser.chrome.toolbar_tips” to false.

Additional info here: http://kb.mozillazine.org/Browser.chrome.toolbar_tips

manythanks tanningto but it doesn’t works, or better, it works only for toolbar tool tips, for tool tips in the web page it doesnt works, so it works exactly in the contrary I would like, maintain the tool tips in the tool bar and hide in the web page lol!

my color scheme is OPENsuse, my GTK2 theme should be oxygen-gtk and gtk3 adwaita, I don’t know what gtk is firefox
but the annoying is the tool tip non only the color

the last you said is what I want to do, be careful where I move the mouse is very annoying lol!

OK - I guess you’re on the latest, or a later version. I’m still on 52.9.0 ESR on which it does disable tool-tips, albeit all tool-tips not just on web pages. Hence my *“If that’s what you really want …” - *Although it’s rather a moot point if it no longer works.

There is another preference that you could try, “ui.tooltipDelay”, which as it’s name implies is the delay between hovering over an item and the display of the tool-tip. Although perhaps that may no longer work either, (I’ve tried it on 52.9.0 and it works as intended).

This preference doesn’t exist by default, so you will have to create a new one, of type “integer”, named “ui.tooltipDelay”, set the value to the delay time you desire. The time is in mS, so for example, if you wanted a 2 sec delay you would use 2000. (The default is 500ms).

Looking into the HTML source, I am sure that the »title« tag of the »a href« element is responsible for these popups:

<a class="title threadtitle_unread" href="showthread.php/535525-MATE-Desktop-Indicators?highlight=mate+desktop+indicators" id="thread_title_535525" ***title=***"I have installed openSUSE Tumbleweed with MATE DE and I want to add the advanced indicators like in Ubuntu-MATE? I have installed Ayatana AFAIK is...">MATE Desktop Indicators.</a>

If you are good at GreaseMonkey or the ad blocker of your choice, you can try modifying or altogether removing these »title« tags before the browser renders the HTML. You could even make it site-specific (or else you would lose those hidden mouse-over jokes in https://xkcd.com/ and other webcomics). However, sometimes these title tags are really informative (on the Linux Kernel Mailing List https://lkml.org/ for example) and can save you the additional mouse click.

Any GreaseMonkey wizards around? :wink:

manythanks tannington, it works, giving 10000ms it seems less annoyinglol!

…manythanks unix111 but I’m a newby at all lol!