Firefox has started a very annoying behaviour!

For as long as I can remember, when I download something, I can click “open containing folder” from the “downloads icon” in FF, and the folder opens in Dolphin. Now for some unknown reason FF has decided to use a file manager “Files”… Which I did not even know was installed!](

I found this when googling about and have followed the advice there, and the entries are added to the file /.local/share/applications/mimeapps.list, but FF still insists on using “Files” I have logged out and back in.

Looks like Nautilus
I don’t have this problem

Thank Caf.
Some days ago I needed a GUI tool which was a gnome thing (can’t remember which, possibly Gsmart or similar), which pulled in a load of other gnome stuff… But that should not have ‘told’ FF to use a different file manager!!
That screen shot is the “help/about” from the ‘new’ filemanager that FF launches, is it nautilus?
edit: yes it is, I just ran Nautilus from Alt-F2.
So how do BAN it? I am used to Dolphin and would prefer it be default, I suppose I could uninstall it from YAST, but that seems extreme. Why has FF decided to prefer it?

Just noticed that dropbox is doing it as well… Grrrrrrrr >:(

Have a look into “Configure Desktop” (systemsettings)->“Default Applications” and check what’s set for “File Manager”.

If that’s ok but it still doesn’t help, enter “File Associations” and set dolphin to be the preferred application for the type “inode/directory”.

Thank you Wolfie, I have checked both of those, and both are set to ‘Dolphin’

IIRC I had this happen once and it was very difficult to clear up, I’m not even sure I did manage it

Oh dear! If you could not fix it Caf, my chances are quite slim! I will consider uninstall/taboo of Nautilus in YAST2 and see how firefox/dropbox react!

Try to run this then:

sudo update-mime-database /usr/share/mime/

I just noticed I have the same problem (I don’t use Firefox very often…), and this fixed it for me, even without uninstalling nautilus.

Here’s an explanation btw.:

Thanks again, Wolfie. But this has not worked either…>:(

Take a look at /usr/share/applications/mimeinfo.cache and ~/.local/share/applications/mimeapps.list , specifically the ‘inode/directory=’ entry

For reference, I have

cat /usr/share/applications/mimeinfo.cache|grep inode

In my home directory, I have it configured as

 cat ~/.local/share/applications/mimeapps.list|grep inode

FWIW, here’s some nautilus history

commit f01e2e9b5fa6dcd0514bdf5efe5f76b4312f1fd3
Author: Federico Mena Quintero <federico gnome org>
Date:   Wed Dec 14 12:12:04 2011 -0600

    Add an org.freedesktop.FileManager1.service file for DBus
    Even though this registers a service for a freedesktop name with a Gnome-specific
    program (Nautilus), we'll just do this for now.
    Later we can discuss in the DBus list how to launch services with generic
    interfaces, but specific implementations for each desktop environment.
    Signed-off-by: Federico Mena Quintero <federico gnome org>

kolAflash reported it here too

For now, I suppose you could edit org.freedesktop.FileManager1.service, and comment the entry

#Exec=/usr/bin/nautilus --no-default-window

or delete it. If using KDE, nautilus should then use the Dolphin file manager instead. You could also lock the nautilus package, so that an update won’t rewrite the file, (or maybe via Apparmor).

Thank you Deano. Reading that bug report, and your advice, I have commented that entry, and firefox now launches Dolphin on request. I think this means that when nautilus updates, it will refresh that file, but I know where to look now. In the bug thread, someone suggests:

My workaround was to “sabotage” the org.freedesktop.Filemanager1 dbus service by creating:


and changing the Exec line to e.g. /usr/bin/false or /usr/bin/true;
this is better since it’s persistent and isn’t affected by system updates… etc.
This makes Firefox use whatever file manager I set in ~/.local/share/applications/defaults.list

I notice that Dropbox still launches Nautilus, which is annoying, but less so than firefox, as the dropbox folder is always in the same place and I can simply launch dolphin myself when I need my dropbox folder.

That’s what I’ve done for now. Easy enough to lock nautilus too. I’m sure a more permanent fix will come.

…I noted that dropbox uses files…, free software…, but also me prefere dolphin, …any workaround?? :slight_smile:

Dropbox for me has changed recently, since it upgraded. The icon in the tray changed and where it used to launch from a click on the tray icon, it no longer does. Now you have to right click the icon to get a context menu. Mine though does launch Dolphin. I don’t have Nautilus installed. And so of course too, Firefox is fine.

I have though noticed some apps present me with some kind of gtk style file manager
IIRC Gimp did so yesterday

Well, GIMP is actually a GTK application (GTK originally stood for GIMP ToolKit, before it became the GNOME ToolKit).
So it is normal that it shows the GTK file select dialog when you open/save a file.
But that’s totally unrelated to launching a file manager…

Note: file select dialog != file manager.
The former one is a function of the used toolkit, the latter one is an application like any other. :wink:

The problem is caused by Firefox, as described in this Firefox bugreport.

The following should solve/workaround the problem for current Firefox versions (e.g. Firefox 34).

Create a textfile (and folders if necessary): /home/YOUR-USER/.local/share/dbus-1/services/org.freedesktop.FileManager1.service

[D-BUS Service]

Now Firefox should respect the filemanager set by xdg-mime.
Use this, to set the filemanager by xdg-mime (for current user only):

xdg-mime default dolphin.desktop inode/directory

Check current xdg-mime setting:

xdg-mime query default inode/directory

I’m currently running quite well with this setting on my system!
Nevertheless this might has bad side effects. For details, have a look here:

Somebody solve this?