Firefox, "Get Mail" Extension, Thunderbird, and Default Applications

Clicking “Read Mail” does nothing, whereas clicking “Compose Message” opens Thunderbird as expected. Thunderbird is properly configured under “System Settings > Default Apps > Email Client”.

Whereas, switching the default email client back to Kmail results in the Get Mail “read mail” and “compose message” functions properly opening Kmail in both instances.

This problem occurred for me before (when using openSUSE v11.1 and earlier versions of the apps), but I don’t recall how I eventually solved it, or whether it was resolved via an update of one of the above apps/extensions. Nonetheless, I’m now confronted by the very same problem again - ugh >:(

Anyone else affected, and/or know the solution? Thanks.

If I were you, I’d rather post this in a Mozilla-related forum. Just a hint.

messing around with this last week, some how I’ve now managed to get:

  • “read mail” still does nothing … but
  • “new message” now opens up Thunderbird (just like it should if you clicked “read mail”), but does not start it in compose message mode like it should.


Have you had a look at this? Changing the e-mail program used by Firefox

Take Care,


Hi Ian,

sorry for the delay in response. Yep, been there, done that. :stuck_out_tongue:

Not sure why the original bug has come about, nor as to how I’ve managed to somewhat reverse the desired functionality.

Anyway, given that I’ve got it partially working, its good enough for now…will just keep an eye out for a proper/correct solution if I happen to come across one.

Installed Firefox 5 last night, and had to update to a newer version of Getmail in order to be compatible with the newer browser version. Anyway, took a few minutes to try to play with this again.

To cut to the chase, in Kmenu > System Settings > Workspace Appearance and Behaviour / Default Applications, under Email Client, within the “use a different email client” entry box, type “mozillathunderbird”. That will ensure that Getmail’s “read mail” function properly opens thunderbird. Not sure why a regular path setting like “thunderbird” doesn’t work properly for me.

To get Getmail’s “new message” function to work properly with thunderbird, just set Firefox’s mailto preference (Edit > Preferences > Applications > mailto ) to “use thunderbird”, as explained on the Getmail website: Get Mail