Firefox freezes when downloading

So guys. I use Opensuse 10.3 since when it was shipped. But now seems to be tired! When i try to download a file with Firefox and mozilla or seamonkey it happens that they seem to freeze. The download window appears and in a flash it closes. Now the only chance i have is to xkill the browser. But if a page is loading it continues. I lost control of the application but seems to continue a life on it’s own. These are the steps i tried to solve this. Fists i downloaded Firefox3, then i cleared the download history. Since no chance i decided to delete all the .mozilla folder in my home. Then the Firefox or mozilla (now i don’t remember exactly) in /lib was also deleted. Again no chance. And if i execute ff from a console, in the case of such a crash, there is no message helping me to undertand. Any idea?

I stupid suggestion… but have you tired moving your download location to a different partition & folder?
Mainly wondering what effect this would have seeing you can browse normally but just have trouble as soon as you want to download something?

Thank you for your interest. I never save to the default location but always use ‘save as’ to different locations according to the content i am downloading. I forgot to say that konqueror works fine as usual

Have you checked Tools > Add ons and installed Fire Uploader? If not, that may be the source of your problem.

No this is not the case. I even did not know this extension. And even i cleared my personal and global profile. I figure it is something related to gtk because konqueror works but it is based on qt. But i have no feedback from the console. So i tried another gtk program like avidemux but it worked even saving a file( this is the problem whith ff).