Firefox freezes on AccuWeather extended forecast webpage

I am using openSUSE 13.2 on a 32-bit Lenovo PC (which also has Windows XP installed).

Recently I’ve had problems with Firefox freezing (requiring me to forcibly terminate it), and pinpointed it to the AccuWeather extended forecast webpage. Firefox works fine with every other webpage I’ve browsed, including on The extended forecast page loads fine in Firefox on Fedora 22, Windows 7, and Windows 8.1, but not in openSUSE 13.2.

I’ve tried everything I could think of to find the cause of this problem. I restarted Firefox in safe mode, but the problem still exists. I reinstalled openSUSE completely, after which the problem was fixed until I installed the ~400 updates recommended by the software applet. Now the problem is back again.

I checked the Web Console and didn’t see any unusual error messages. When the Developer Tools pane is open though, the problem seemed to disappear. However, when I scrolled down, then Firefox froze, so it seems like the source of the problem is an element that’s about halfway down the page.

I don’t know if this is a problem with Firefox or openSUSE, but I would guess the latter since the page loads fine in Fedora. This seems like very strange behavior to me. Are there any ideas as to what might be causing this?

Do you maybe have an nvidia card and are using the noveou driver under plasma5?
I had freezes with Firefox running on plasma5 under LEAP my solution was installing nvidia’s propitiatory driver
or maybe you forgot to add the packman repo as Firefox needs packman’s build of gstreamer for mp4 support.

Thanks, I saw a thread mentioning that, but my PC has an Intel graphics card and is using KDE4.

When I load a page containing an MP4 video (like this one), the video is replaced with a gray box saying “No video with supported format and MIME type found”, but it doesn’t make Firefox freeze so it doesn’t seem like that’s causing the problem.

How much memory do you have Firefox has become a true memory hog

in a console run top to monitor usage or press ctrl-esc

My PC has 1GB of memory, and Firefox was only using around 160MB when it was hanging. I took a screenshot of the Task Manager but it doesn’t seem like I’m able to attach a screenshot, so I uploaded it to Google Drive:

try chromium just to make sure it’s a Firefox issue and not something hardware or OS related

OK I did and the page loaded fine in Chromium. Does this mean it’s a Firefox issue I should report to Mozilla?

maybe, I use Firefox and I don’t have that issue, it could be an addon, try running Firefox in safe mode, if it does the same by all means report it, all hardware is not the same.

The problem also exists in safe mode, so I plan to report it to Mozilla. In the meantime, I figured out that the ESR version of Firefox does not have this issue, so I will use it for now.

Thanks for helping me identify Firefox as the cause of the problem.

But if it’s working with FF on other OS’es then it might also not be a problem with FF :slight_smile:
Are you using the exact same version on FF on other OS’es ?

Yes, I’m using Firefox 43 on WinXP, Win7, Win8.1, and Fedora 23. Loading the page works fine even in WinXP which is on the same PC that has openSUSE.

The problem disappeared after I downgraded to the ESR version of Firefox (38), although that’s only a temporary solution. This would cause me to think that the problem is with Firefox, but there were also a few libraries used by Firefox that had to be downgraded when I installed the ESR version.

Accu weather work fine with me with the normal distro FF. How much memory? DO you have lots of may addons?

Have you gotten all updates?
What video card/driver?

The PC has 1GB of memory, and it doesn’t seem like it’s short on resources (see post #5). The only add-ons I have installed are Forecastfox (fix version) and uBlock Origin. Oddly it’s only the Extended forecast page that doesn’t work, otherwise Accuweather works fine.

I have all the latest updates installed from the Software Updater applet (except I’m using the ESR version of Firefox).

The PC is a Lenovo ThinkCentre M55p, which has an Intel Q965 chip with “Integrated Intel Graphics Media Accelerator 3000”. I haven’t installed any specific driver for it in Linux. I tried turning off hardware acceleration in Firefox and it didn’t help, but I guess that doesn’t necessarily eliminate the hardware as a cause of the problem.

1 gig is pretty light these days right now my machine says it uses 335meg for FF. try disabling all add-ons and then add back one by one to see if difference.

When I had 2 gig memory FF would fold on me if I had a VM open. Simply out of memory. I don’t think FF likes swap??? Any way with 8 gig I never have memory problems and seldom if ever touch swap

I realize that 1GB is on the low end by modern standards, but on my machine Firefox was using only 160MB when it was hanging and it was the only app I had running. I’ve tried running Firefox in safe mode which disables all the add-ons and it didn’t make a difference. Since safe mode also disables hardware acceleration, it seems unlikely to me that the problem is caused by low memory, add-ons, or hardware, which is why I think it is probably a Firefox bug.

is hardware acceleration disabled in Firefox if not disable it, is firefox installed from the main or the mozilla repo?
what Desktop are you using when Firefox crashes, Firefox might be using only 160M of RAM but the Desktop might need more then you have, it could be swapping a lot, try a lighter Desktop (Lxqt or Lxde)

I’ve tried disabling hardware acceleration and it didn’t help. Firefox is installed from the main repo, but I tried replacing it with version 43.0.3beta from the mozilla repo and that didn’t help either.

I’ve also tried using GNOME and Plasma5 instead of KDE4, but neither of those are light desktops. I could try a lighter desktop, but I really don’t think that’s the problem and would only do so as a last resort. I haven’t had any trouble playing YouTube videos, which I would think is more resource intensive than Accuweather.

afaik opensuse does not edit any of the mozilla code they just compile it against the opensuse libraries if it works on another Linux distro it should with opensuse (maybe read on)
mozilla always had issues with intel’s graphics and those are part of the Linux kernel.

openSUSE 42.1 uses the 4.1 branch of the Linux kernel while Fedora 23 uses 4.2, intel graphics are build in the Linux kernel so there could be an issue with intel’s driver in the 4.1 kernel branch this could be an openSUSE kernel issue you should open a bug report with opensuse’s bugzilla and see what they suggest.
there are newer semi official kernel packages but if it is a bug with intel’s graphics it might get back-ported in the 4.1 kernel.

ps. 1 Gib or ram is too little for running plasma5 or Gnome with a 64bit OS as those are resource intensive especially gnome, in plasma5’s setting you should disable all aye candy but I’d still suggest using a lighter Desktop like lxqt or lxde with openbox.

oops I didn’t notice you wore using 13.2 that has an older kernel 3.16.7 my sugestion still stands open a bug report
take note that the intel gpu is not Q965 you need to do a little more searching to get the real hardware the text below is from mozila’s wiki

The “GPU family” below doesn’t necessarily match the “Adapter Description” in about:support. Indeed, Intel has multiple, overlapping product numbering schemes. For example, the “965 chipset family” encompasses the Q965 which is a GMA 3150 chip, and the G965 which is a GMA X3000 chip. Details of your Intel graphics chip are available from the Adapter tab of the Display Settings dialog in Windows. For example, in Windows Vista, one way to get to this in Windows Vista is right-click the desktop, choose Personalize > Display Settings > Display Settings > Monitor > Advanced Settings… > Adapter, and look for the Adapter String under Adapter Information.

also saying that Firefox runs on Fedora 23 on a different pc is null as I do believe you have a hardware (driver) issue on that particular pc

Thanks, I’ll file a bug report. I had tried upgrading the kernel using the Kernel:stable repo (4.3), and it didn’t make a difference, so I can confirm that this bug still exists in the kernel.

I would upgrade to openSUSE 42.1, but I can’t because the PC is 32-bit. At least that makes the 1GB of memory more substantial than if it was 64-bit.