Firefox fails to start after upgrading to openSUSE 11.2

Hi,

After upgrading from opensuse 11.1 to 11.2 via zypper dup. Firefox won’t start anymore. When i try to launch Firefox from konsole following error presents:

/usr/lib/firefox/firefox: symbol lookup error: /usr/lib/xulrunner-1.9.1.4/libxul.so: undefined symbol: gdk_x11_window_get_drawable_impl

Following versions installed:

MozillaFirefox-3.5.4-1.1.2.i586
mozilla-xulrunner191-1.9.1.4-2.1.2.i586

Tried also reinstall firefox and xulrunner multiple times. Also tried different versions of xulrunner. Is this issued caused by xulrunner or something else ?

Thanks for any help.

First thing I would try is a rename of the hidden .mozilla folder to .mozilla-old

Thanks for reply, but no help. I also tried to create a new account, but this error still occurs.

Are you using gnome?.

I’d be interested in seeing your repos

zypper lr -d

I’m using KDE.

# | Alias                       | Name                        | Enabled | Refresh | Priority | Type   | URI                                                                      | Service
--+-----------------------------+-----------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------+--------
1 | GNOME:Factory               | GNOME:Factory               | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_11.2/  |
2 | KDE:Backports               | KDE:Backports               | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.2/  |
3 | OpenSUSE_11.2_Factory_GNOME | OpenSUSE_11.2_Factory_GNOME | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Factory/openSUSE_11.2   |
4 | mozilla                     | mozilla                     | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/         |
5 | mozilla:beta                | mozilla:beta                | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla:/beta/openSUSE_11.2/   |
6 | mozilla:legacy              | mozilla:legacy              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla:/legacy/openSUSE_11.2/ |
7 | repo-non-oss                | openSUSE-11.2 Non-OSS       | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/             |
8 | repo-oss                    | openSUSE-11.2 OSS           | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                 |
9 | repo-update                 | openSUSE-11.2 Updates       | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.2/                                |

Thanks,

Disable 5 and 6
Change priority of 4 to 90

Now Use Software Management - Filter by repo
select the Mozilla
Use the System Package switch to use this repo (principle shown here: ImageBam - Fast, Free Image Hosting and Photo Sharing)
Accept

Sorry. That did’n help either. I noticed that same error occurs with Mozilla Sunbird and Thunderbird.

So remove all the mozilla repos and switch everything back to default oss/updates

See if that helps

Hi.
I had similar problem and it was solved removing Gecko media player. Good luck!

Problem solved! At least for now… I’m not 100 % sure what i did, but i downgraded firefox and related packages (xulrunner) to orginal versions from 11.2 repo. Slept over night and rebooted my computer and firefox is running nice and smooth. :slight_smile:

Thank you for replies!

Like I suggested then;)
Well done!

Finally i figured out what the main problems was. For some reason i had installed long time ago gtk2+ from sources. I compiled version 2.18.1 from gtk.org and now it’s working perfectly.

Is there anyway to get rid of that compiled version of gtk+2 ? it’s now located in /usr/local/lib -folder and seems that gtk based programs tries to use libs from there. Altough is allright but now i must always compile latest gtk to stay updated :smiley:

ok. Seems that executing “make uninstall” in gtk+2 source directory did the trick. Now also gtk themes started to work.