firefox drop-down menus vanish when scrolling onto them

This is a problem I had in Ubuntu some years ago that just seemed to go away; sporadically I will want to select a website by positioning the cursor over the drop-down arrow to the right side of the url box- after the list is displayed it will vanish immediately when I attempt to position the cursor over it to make a selection. Minimizing then maximizing Firefox resolves it.

A minor problem yes - but it would be nice to not have to deal with it.

Does anyone have any suggestions ?

Thank You.

This is a problem I had in Ubuntu some years ago that just seemed to go away; sporadically I will want to select a website by positioning the cursor over the drop-down arrow to the right side of the url box- after the list is displayed it will vanish immediately when I attempt to position the cursor over it to make a selection. Minimizing then maximizing Firefox resolves it.

A minor problem yes - but it would be nice to not have to deal with it.

Does anyone have any suggestions ?

Thank You.

So you need to tell us a bit more about your setup to help. I have not seen the problem you describe and so it must be related to your setup. I am using openSUSE 11.4, 64 bit, KDE 4.6, Firefox 5.0.6 and my graphics system is nVIDIA GTX 560 and driver 280.13 loaded the hard way. I want to know the same info for your setup. The My Computer icon can help with some of this info if you are not sure.

Thank You,

Thanks for getting back James. My config is same as yours up to the graphics - it is an on-board ATI Radeon on a Gigabyte board. Not sure about the driver but will dig for it if need be.

Sometimes I find solutions in these forums to be well known without details being required. Of course, if I had included them initially you wouldn’t have had to ask…

stansaraczewski Thanks for getting back James. My config is same as yours up to the graphics - it is an on-board ATI Radeon on a Gigabyte board. Not sure about the driver but will dig for it if need be.

Sometimes I find solutions in these forums to be well known without details being required. Of course, if I had included them initially you wouldn’t have had to ask…

If you have AMD/ATI and you are not loading their Catalyst driver, you surely need to consider it in my opinion. I would look at the following thread for guidance. I am pointing you to the end (most recent), but reading back a little might be helpful.

Upgrading ATI driver with atiupgrade - Page 8

It is my opinion that the issues you are seeing are graphics driver related and it is possible loading the proprietary video driver might be helpful. Please_Try_Again seems to have a handle on this with his scripts and is a great asset to our forum. Of course, if you have money burning a hole in your pocket (as opposed to just having a hole there and losing your money) I highly recommend switching to nVIDIA where I have found the performance and driver support (from nVIDIA) to be very good. Still, you got to try Please_Try_Again’s solution before you do anything else.

Thank You,

I have had nVidia on a different rig that lost the mobo, and it was indeed nice. I don’t have money to burn or a hole in my pocket although this mobo is a midrange, and the AMD is a lower end hex core and I have 16gb memory. It really doesn’t cost all that much when you do it yourself.

Thanks for your assistance.

How do I discover what driver is being loaded ?

How do I discover what driver is being loaded ?

Normally I just look into the My Computer icon display on the bottom right. You can also open up a terminal session and issue the lsmod command. Then ALL loaded modules appear, including that for video. I am not sure what name the driver you use might be going by.

Thank You,

Pretty interesting display -

radeon 986425 3
ttm 74373 1 radeon
drm_kms_helper 36694 1 radeon
drm 232428 5 radeon,ttm,drm_kms_helper
i2c_algo_bit 6342 1 radeon

What is it telling me ?

When displaying module information (using lsmod) such as below:


radeon                   986425   3 
ttm                        74373     1    radeon
drm_kms_helper   36694     1    radeon
drm                       232428    5   radeon,ttm,drm_kms_helper
i2c_algo_bit           6342       1    radeon

The first column contains the name of the module.
The second column refers to the memory size of the module, in bytes.
The third column lists how many instances of the module are currently loaded. A value of zero represents an unloaded module.
The fourth column states if the module depends upon another module to be present in order to function, and lists those other modules.
The fifth column lists what load state the module is in: Live, Loading, or Unloading are the only possible values.
The sixth column lists the current kernel memory offset for the loaded module. This information can be useful for debugging purposes, or for profiling tools such as oprofile.

The module info you supplied did not include everything. The descriptions came from this link: 4.2.21. /proc/modules

Thank You,

"The module info you supplied did not include everything. "

I copied anything with the word ‘radeon’.

So here is the output for nvidia on my system:

nvidia 11701423 40 - Live 0xffffffffa0258000 (P)

The “Live 0xffffffffa0258000” seems to be missing, for columns 5 & 6. Not sure what it would mean when they are gone.

Thank You,

So you’re using the radeon driver. The proprietary driver is called fglrx. You can install the latest version by installing and typing atiupgrade in a root terminal. When you’re upgrading another fglrx driver, you have to run the script in console mode (runlevel 3). In your case, it won’t be necessary since you don’t have any fglrx module loaded. I don’t know if the fglrx driver will solve your problem, but it is usually better.

Here’s how to install the latest ATI driver:


su -l
zypper ar http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_11.4/ PTA
zypper refresh -r PTA
zypper in atiupgrade
/usr/bin/atiupgrade

It’s going to take some time (it has to install the kernel sources and compile the module). So be patient.

I thank you very much for your reply. If we are not sure that it will solve the problem I may just hang around a bit since this is a very minor problem and I could introduce a greater problem if I happen to fat finger it. A couple of days ago I used the automatic install of the proprietary driver on my Ubuntu system - saw a semitransparent icon to the bottom right stating ‘AMD - unrecognized hardware’ - and it wouldn’t go away till I was able (fortunately) to back it out. Is there a backout procedure for FGLRX ?

stansaraczewski, it is kind of funny to me that after our discussion on kernel modules being loaded and such I decided to write a script that can make it easier to look at the kernel modules that you have installed. Please look at the following thread and see if this is helpful to you.

S.K.I.M. - SuSE Kernel Installed Modules - A lsmod replacement - Creates an Alphabetized Mod Listing

Thank You,

This message appears when the model of the graphic card is too recent and still unrecognized by the driver, although it works (normally). atiupgrade install the latest version available on ATI website, so there is a chance that you won’t see this message under openSUSE. However, if you would install fglrx from the official ATI repo under openSUSE, you would see it, as this driver is often outdated. There is also an unofficial ATI repo, which provides the latest driver. Under Ubuntu - AFAIK - you can just deactivate the proprietary driver to switch back to the radeon or radeonhd driver. Under openSUSE, you can replace fglrx by radonhd or radeon in /etc/X11/xorg.conf and - if needed - boot with the option nomodeset.

modinfo fgrlx won’t tell you which Catalyst version is installed. The latest version is 11.7.

atiupgrade or the following command would under openSUSE:

grep -i catalyst /etc/ati/amdpcsdb.default

It doesn’t work on Maverick with the fglrx version I have, maybe on Natty (which I didn’t install). You’ll have to look in Catalyst Control Center under Ubuntu.

Thank you both for your efforts. I’ll pursue this over the weekend.