Firefox doesn't open from clicking on link Thunderbird

OS 11.2 Thunderbird and FF 3.5.4 Clicking on a link in an email doesn’t call FF. How do I make the connection?

I had OS 11.2 RC2 it worked fine after upgrading to GM it broke the connection.


Hi Ron,

IMHO The “Default Application” system settings has a bug or is broken.

I have a workaround so that you can launch Firefox from within Thunderbird.

Please read refer to my earlier post below: **Cannot launch URL from Thunderbird 3.04b to Firefox"

Good Luck!

That didn’t work,:frowning:


A solution : Cannot launch URL from Thunderbird 3.04b to Firefox - openSUSE Forums

Well this is documented in a bug report:

A workaround seems to me is to add into ~/.kde4/Autostart/firefox

the two lines:

gconftool-2 -s --type=string /desktop/gnome/url-handlers/http/command "/usr/bin/firefox \"%s\""
gconftool-2 -s --type=string /desktop/gnome/url-handlers/https/command "/usr/bin/firefox \"%s\""

Don’t forget to make the file executable. I do not have another solution at the moment, but it works for me.


Ah ha!! From what I read in Novell Bugzilla, this originally started as a possible GNOME packaging problem.

I know for a fact this worked ( Thunderbird and Firefox ) in 11.2 Milestone 1 through Milestone 8. It was broken by the time 11.2 RC1, RC2 and openSUSE 11.2 were available.

Any thoughts?

This a follow up to the bug found about Thunderbird not being able to start up Firefox.

  • Add the Stable 4.3.1 Core link to Yast
  • Click on Switch system packages to the versions in the repository openSUSE 11.2 Stable Core 4.3.1
  • After updating - Log out and reboot your system

Add this link to Yast below:

[Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2](

Good Luck!

After updating the 4.3.1 Stable Core library in openSUSE 11.2, Thunderbird now launches Firefox in KDE-4.3.1.

Let me know how it turns out.

Good Luck!

I don’t understand. How do you do this?

[/QUOTE]Add this link to Yast below:[/QUOTE]


[Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.2](

Good Luck![/QUOTE]

Thanks, we will get there eventually.

  1. Navigate to the taskbar - far left corner and click on the green gecko

  2. Select Computer → Yast - Type in your password

  3. Navigate to Software → Add-On Products. This will start the Package Manager.

  4. Click on the Add button -->Specify URL → Click on the Next buttton

  5. Copy and paste the link I provided in the “URL field” and create a name in the Repository Name field i.e. Stable 4.3.1

    The rest is straight forward about updating the software.

Sorry, but where can I find this functionality?

Click on Switch system packages to the versions in the repository openSUSE 11.2 Stable Core 4.3.1

Is it within the Package Manager? And what’s the difference, I mean isn’t KDE 4.3.1 we all have when installing OpenSuse 11.2? Or is the “official” 4.3.1 something else than the one in the rep?


After you add the Repository URL of the KDE 4.3.1 Stable Core, restart the Yast Package Manager. Maximize the Package Manager to a full screen.

In the Name column -on the left side of the Package Manager, click once on the KDE-4.3.1 Stable Core repo.

Select View → Repositories. On the Repositories tab, you will see:

| Switch system packages to the versions in this repository(name of repo)| |

Click once on it to activate the update.

In the meantime I’ve found any easier fix for the Thunderbird - Firefox problem.

See below:

After reviewing Novell Bugzilla, I have found the easiest fix until an update will be available.

The following steps are as follows:

Open konsole or xterm and type in the following first line:

gconftool-2 -s /desktop/gnome/url-handlers/http/command '/usr/bin/firefox %s' --type String

Press the [enter] key.

gconftool-2 -s /desktop/gnome/url-handlers/https/command '/usr/bin/firefox %s' --type String

Press the [enter] key once more.

Close konsole or xterm and restart Thunderbird.

  •  Navigate to Tools --> Add-ons and click on "Browse All Add-ons"
  • You will now see Firefox launch every time including Help Contents, Release Notes and What’s new

It works!!

BTW The KDE-4.3.1 Stable Repo includes the most recent patches since 11.2 had been released.

Thank you very much, didn’t know this feature of the package manager.

The easy solution you find is the one I used so far (as stated above) :slight_smile:

Same problem here

(openSUSE 11.2, Thunderbird 3.0b4, Firefox 3.5.5)

Hi Folks,

I have tired all of the solutions noted here and I am still not able to make links in thunderbird open firefox. (I even tried making a sym link from enigma to firefox) Can anyone suggest how to see what is going on under the scenes?