firefox doesn't load webpages all of a sudden


Recently I’m suffering problems with firefox. Lots of webpages just don’t fully load anymore including and They show a part of the page and then it seems to hang. Some pages won’t even load at all. Waiting for like a minute doesn’t help. Firefox used to work fine. I’m not sure what the cause could be. Defenitely not hardware, since Konqueror (and any other browser or program using internet) runs just fine. I remember I installed a few add-ons for firefox (like down-them-all, download status bar and a dictionary) but if I disable these add-ons the problem remains. I also remember I installed a few software upgrades for some packages I do not remember (nothing with the name firefox in it that I am sure). But since I do not remember the names of the packages it is hard to downgrade them back and see if it helps. Unless there is some kind of log somewhere of the software management?
Anyway does anyone have a clue of what’s going on here? Without firefox my opensuse is worthless…

I also tried this: downgrade of firefox 3.0-0.2 to firefox 3.0-0.1 (both from official opensuse update site, never installed something through mozilla repo) but no success. I also tried deleting my ~/.mozilla/firefox folder thus resetting all configuration but again no success.

I’m using 11.0 64bit gnome.

Forgot to mention: disabling firewall doesn’t help neither

fixed the error with info found here: Problematic extensions - MozillaZine Knowledge Base

Look at the DownThemALL section. In about:config I had to change network.http.max-persistent-connections-per-server and switch it back to its standard value. Now browsing is lightning fast again:)