Firefox crashes the swstem (unless it's safe mode)

Hello :slight_smile:

Recently Firefox started causing the system to freeze and the only solution would be to force close/start the laptop. It was just random, and then after I tried to “refresh” it, every time that I open it, the whole system freezes. I tried re-installing but it didn’t work. It only works when I start it in safe mode from terminal.
I’m using tumbleweed Gnome with Firefox 61.0.1
(From my little research, maybe it’s related to some graphical card driver problem but I don’t know. I’m using an Intel graphical card and supposedly the last build of Tumbleweed).

Thank you very much for any support :slight_smile:

I’m sorry for the double post as I couldn’t update the first message. After re-installing Firefox and deleting the files .Mozilla, now with the new installation/profile, it seems that only specific websites results on the system freeze (unlike previously) including the login page for Yahoo mail.
Any help is welcome and thank you.

Since the newest Firefox 60+ (not the old ESR) Firefox seems to need swap to be as large as ram or it freezes the system.

After I made swap larger then ram - the Firefox freezing Linux have stopped. Even though no real swap is being used.

Firefox still sometimes goes away doing file transfers but it has not locked up my linux since swap is larger then ram.

Thank you. I have 2GB of Ram and 2GB of swap partition (technically, Gparted is showing 1.95GB). If safe mode is working, maybe there is an option to deactivate such feature?
(I’m hesitant to allocate more Swap as it is the last partition, so I would need to reallocate from another partition with the risk of losing data).

Update: Upgrading Swap to 4GB did not solve the problem… I tried also Waterfox and Firefox 62 beta, they both have the same issue. So, maybe somehow it’s related to a recent kernel/graphic card update that is incompatible with one of Firefox mechanisms (which is not somehow used in safe mode).

Again, any help is appreciated and thank you.

(This forum needs an “edit” option, or maybe a moderator can merge my last two messages :slight_smile: )

I’m sorry for the multiple posts, just wanted to share that when webgl.disabled is set to True (in about:config), the problem disappear (and that’s most probably why Safe mode works).
And I think this confirm that the problem is linked most probably to the latest drivers update in OpenSuse. I hope it will be fixed soon.

I know that this is just anecdotal, but my laptop (Lenovo Toga 3 Pro, Intel graphics, Tumbleweed) had been exhibiting random system (all interfaces freeze after ½ to 4 hours operation) for about a month. I had been investigating the broadcom-wl kernel module without success.

I disabled in Firefox and the system has been stable for almost 40 hours now.

thanks for this post, i noticed the same behavior yesterday on my system to:

glad to hear that it does not seem to be a hardware issue/defect (because my laptop is relatively new). I did not tried safe mode nor but i will try that soon. Can someone confirm that this is a bug? Is it a firefox bug or an intel driver bug? Is it known?
And what does do?

I had the same problem in two different laptops. A bug this serious should have not made it through to Tumbleweed. I hope it gets fixed soon.

Where is the link to your bug report? You made one, of course, since that is normally the only way a bug gets fixed.