Firefox Crashes OS

I decided to return to Linux today and so I put openSUSE 12.1 back on my computer. For the most part, things have worked fine, but for some reason Firefox is currently unusable. It worked fine at first, now whenever I try to open it, my entire computer slows down to the point where I can barely move my mouse, and then after a few seconds I can move my mouse but everything else is still frozen. When I try to run it from the console, I get the following output:


ned@linux-gty4:~> firefox
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).

I can’t remember if this problem started happening after I installed flash, but that’s a possibility.

Thanks.
-ascii

Bump, I could really use some help here.

Firefox runs just fine here. I don’t have the problems you describe.

As for that “nss-shared-helper” message: yes, I get that and just ignore it. I think it is intended only to be informational.

My best guess is that you are having a graphics problem, and that the only thing firefox is doing is triggering that problem.

I’m not a graphics card expert. But I suggest you post info about your graphics card, and perhaps somebody familiar with the problem will be able to help.

There’s another possibility - maybe you have a firefox extension that is causing problems. Try creating a new user, and see whether firefox works find for that new user account.

Video card? driver?