Firefox colors

Just installed 11.3 with KDE and my color scheme doesn’t seem to affect firefox. I added one of firefox’s personas, but it doesn’t change the scrollbars, menus… Suggestions?

Use of Firefox “personas” only works with the Firefox “Default” theme. If using the “Default” theme (or any other theme), go to Edit → Preferences → Content" and click on “Colors”. There are two boxes to check: “Use System Colors” and “Allow pages to choose their own colors, …”.

Selecting “Use System Colors” should allow your KDE color scheme to be used. If you are using a theme other than the “Default”, you may need to uncheck the “Allow” option.

i think that is for the actually webpage to be displayed.
I unclicked it and it dit nothing. I remember that there is an option in the Appearance App where you can force (i assume) to get other apps to use the coloring. But it did not work for me for some reason. No matter what i check or uncheck, nothing happens. :frowning:

The issue lies with Systemsetting > Appearance > GTK Styles and Fonts. By default the style that is used on 11.3 KDE for GTK applications is set to Oxygen-Molecule. This works fairly well to give GTK applications an Oxygene look. The limitations of Oxygene-Molecule are that is does not make proper use of your KDE color scheme.

Solutions that I can think of are

  • Use the Oxygene-Molecule color scheme (if is is there, that is) along with Oxygene to colorize and style KDE applications.
  • Live with the differences in coloration between KDE and GTK applications that exist when you use Oxygene and Oxygene-Molecule
  • Use QtCurve for KDE and GTK applications instead. It is very successful in styling and colorizing both types of applications in a like fashion. Note though, that while QtCurve can have many, many appearances it never really looks like Oxygene. (qtcurve-KDE4 1.2.0 and qtcurve-GTK 1.2.0 are available in the 11.3 OSS repositories)

Thanks Lord Emsworth, QtCurve did the trick.