Firefox cant play mp4

Hi I have a slight problem.
It is a few weeks already since firefox (or any other browser I have installed) cant play mp4s, console gives error Media resource x could not be decoded.
I had simillar problem after installation (which is normal) back then I could not use even VLC which now works.
I tried to install libs but I either already have them or cant find them (I used packman)

Thanks for any help guys :slight_smile:

Sorry, but this is unclear.

Do you mean with “used” you do not use it anymore?

And when you still “use” it, what do you man with that?

What you should do with Packman is:

  • add the Packman repository;
  • do the vendor switch to that repository.

I ask, because there are people that think that just adding a repo is enough to magically use it.

Few months ago I just added repository and everything started working.
Now just web browsers don’t work (I still have packman enabled).
Anyway, I switched to packman as you suggested via YaST and it works again, thank you.

Nice it works again.

Just having a repo enabled does not mean more then you being member of the city library. As long as you do not go there and loan books, not much happens. :wink:

I think I’m having a similar problem. Some YouTube videos will just not play, returning me this error: “An error occurred. Please try again later.”
Opening Web Console (Ctrl+Shift+K) and reloading page I see errors like this:

Media resource blob: could not be decoded.
This error message will be blank when privacy.resistFingerprinting = true.  If it is really necessary, please add it to the whitelist in MediaError::GetMessage: NS_ERROR_DOM_MEDIA_FATAL_ERR (0x806e0005) - mozilla::MediaResult mozilla::FFmpegDataDecoder<59>::InitDecoder(): Couldn't open avcodec

So it seems like a codec related issue, but I have the following packages installed “libavcodec58_134” and “libavcodec59”, do I need something else?

The video I’m talking about is this:
I noticed Japanese fonts lacked subpixel rendering and looked all jagged inside Firefox, so I decided to look for a fix solution on YouTube, and first video that came up refused load, every video I tried on her channel is not loading. Videos I watched previously played just fine.

Can you help me?

Working here.

Do you add the Packman Repo and switch to the packages from Packman?
Firefox needs ffmpeg4 from Packman to play all codecs.

Did you read the above thread? It says you should do the Vendor Switch to the Packman repo. Did you do that?

See comment #2

Yeah, I read it, but thought maybe additional repos are not necessary, it sounded a bit… radical to me, but I just started reading wikis on “Build Service application blacklist” and “Additional package repositories”, and now I’m starting to understand that third-party repositories are indeed necessary, and more reading is necessary.
I was wondering, is there a command to pull just the necessary packages from a 3rd party repo without actually adding additional repositories?
And now I’m thinking, maybe we should reject websites like YouTube…
Thank you for your replies.

youtube and other sides uses h264 or h265 codec.

openSUSE does not ship any propriety codec, so the ffmpeg4 offered by openSUSE does not ship f.e. h264 codec.
Packman is building the ffmpeg4 without regression.

So add the Repo:

zypper ar -f -p20 packman

switch the installed packages to the Packman ones, if possible:

zypper dup --allow-vendor-change --from packman

Please do not be stubborn. Switching to the Packman repo is the only way to get all Multi-media functioning.

I also assume that, as long as you did not do the switch, not many people will even try to help you with a multi-media problem, because it is very logical that that things will not function…

I do the switch (after an install allreday for > 15 years. I never had to install any extra codecs. I never had a multi-media file not playing.