Firefox cannot toggle addo-ons status as normal user

Hello community,

I run Firefox 28.00 on OpenSuse 13.1 64 bit KDE. I need to run a java applet and therefore wanted to activate Iced-Tea web Plugin via tools add-ons in Firefox. However, it is gray (disabled) and I cannot seem to change this. Moreover, I cant seem to change the status of any plugin.

The drop-down menu just does not change.

Any ideas?

Trying this as root, it works. However, I wont run a browser as root.

Any ideas?

PS: Strange enough, using about:config to activate java, works

As you should not login in the GUI as root. that can not be tested.

Use another user to test if it is bound to a user environment.

Can you enable/disable the add-ons from safe mode? Start it from a terminal

firefox -safe-mode

Well, I did run it with kdesu just to check…and it works as expected…also works with a new user…

thank you.

You do not report if you tried deano_ferrari’s suggestion (ot may help!), but it looks like there is something wrong in the ~/.mozilla directory of that user. You could try if it helps when you move it away (stop FF first of course

mv .mozilla mozilla-saved

Then start FF again, it will create a fresh .mozilla and you can test if the problem persists.

Of course this action will remove any changes you have done to your FF configuration.