Firefox can not play some Youtube clips

Hello,
I have a problem (or Firefox has): I can not open some clips in Youtube for last couple days. When I click link(s), it redirect to YT site, but on screen appears just gray rectangles instead of pictures wiht pictures of clips in What it is need to do to make YouTUBE clips work properly? My FF version is 60.2.2(esr).

Thank you for answering my questions.

maybe it’s a firefox add-on have you tried running firefox in safe mode
hit the three horizontal lines on the right then Help then Restart with addons disabled
youtube should work out of the box it does for me on LEAP 15
first try firefox with a clean user account so we can be sure it’s not something in your mozilla profile (you can make a fresh account with yast)
if a clean Firefix can’t access youtube it’s something system related in that case
tell us your repo list

zypper lr -d

tell us your ffmpeg libreries

zypper se -si libav

I tried with new user account - it works properly .

Command
zypper lr -d

gives this:


zypper lr -d
#  | Alias                               | Ime                                     | Omogućeno | DNS provjera | Osvježi | Prioritet | Vrsta  | URI                                                                      | Servis
---+-------------------------------------+-----------------------------------------+-----------+--------------+---------+-----------+--------+--------------------------------------------------------------------------+-------
 1 | Leap_15.0                           | VideoLAN Repository                     | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.videolan.org/pub/vlc/SuSE/Leap_15.0/                     |       
 2 | google-chrome                       | google-chrome                           | Da        | (r ) Da      | Da      |   99      | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                      |       
 3 | http-download.videolan.org-19d76f7b | SuSE                                    | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.videolan.org/SuSE/Leap_15.0/                             |       
 4 | http-opensuse-guide.org-ceb99342    | libdvdcss repository                    | Da        | (r ) Da      | Da      |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                       |       
 5 | http-packman.inode.at-860e8b69      | Packman Repository                      | Da        | (r ) Da      | Da      |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/                         |       
 6 | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1                    | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/            |       
 7 | openSUSE_Leap_15.0                  | Firefox Repository                      | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.0/    |       
 8 | repo-debug                          | openSUSE-Leap-15.0-Debug                | Ne        | ----         | ----    |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/      |       
 9 | repo-debug-non-oss                  | openSUSE-Leap-15.0-Debug-Non-Oss        | Ne        | ----         | ----    |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/  |       
10 | repo-debug-update                   | openSUSE-Leap-15.0-Update-Debug         | Ne        | ----         | ----    |   99      | NONE   | http://download.opensuse.org/debug/update/leap/15.0/oss/                 |       
11 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss | Ne        | ----         | ----    |   99      | NONE   | http://download.opensuse.org/debug/update/leap/15.0/non-oss/             |       
12 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss              | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/        |       
13 | repo-source                         | openSUSE-Leap-15.0-Source               | Ne        | ----         | ----    |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/     |       
14 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss       | Ne        | ----         | ----    |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/ |       
15 | repo-update                         | openSUSE-Leap-15.0-Update               | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                       |       
16 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss       | Da        | (r ) Da      | Da      |   99      | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                   |       
17 | skype-stable                        | skype (stable)                          | Da        | (r ) Da      | Da      |   99      | rpm-md | https://repo.skype.com/rpm/stable/                                       |       
18 | skypeforlinux                       | skypeforlinux                           | Da        | (r ) Da      | Da      |   99      | rpm-md | https://repo.skype.com/rpm/stable 


Result of

zypper se -si libav
is:


S  | Ime                     | Vrsta | Verzija          | Arhitektura | Repozitorij         
---+-------------------------+-------+------------------+-------------+---------------------
i+ | gstreamer-plugins-libav | paket | 1.12.5-lp150.3.2 | x86_64      | Packman Repository  
i+ | libavahi-client3        | paket | 0.6.32-lp150.3.2 | x86_64      | openSUSE-Leap-15.0-1
i+ | libavahi-common3        | paket | 0.6.32-lp150.3.2 | x86_64      | openSUSE-Leap-15.0-1
i+ | libavahi-core7          | paket | 0.6.32-lp150.3.2 | x86_64      | openSUSE-Leap-15.0-1
i+ | libavahi-glib1          | paket | 0.6.32-lp150.3.2 | x86_64      | openSUSE-Leap-15.0-1
i+ | libavc1394-0            | paket | 0.5.4-lp150.1.12 | x86_64      | openSUSE-Leap-15.0-1
i+ | libavcodec57            | paket | 3.4.4-lp150.9.2  | x86_64      | Packman Repository  
i+ | libavdevice57           | paket | 3.4.4-lp150.9.2  | x86_64      | Packman Repository  
i+ | libavfilter6            | paket | 3.4.4-lp150.9.2  | x86_64      | Packman Repository  
i+ | libavformat57           | paket | 3.4.4-lp150.9.2  | x86_64      | Packman Repository  
i+ | libavresample3          | paket | 3.4.4-lp150.9.2  | x86_64      | Packman Repository  
i+ | libavutil55             | paket | 3.4.4-lp150.9.2  | x86_64      | Packman Repository  

Sorry, i use OpenSUSE in Serbian, but I think it would’t be problem (‘da’ means ‘yes’, ‘ne’ means ‘no’)

I’m thinking it’s something with your firefox profile a bad addon or a bad config file I’d recommend doing a Firefox refresh
https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
this will keep your Bookmarks and Logins but it will remove all your addons so make a copy of the addons you use for example in the Firefox address bar go to

about:support 

copy your list of addons and save it to a text file so you can reinstall them latter from AMO https://addons.mozilla.org/
as always when multimedia is in question do a vendor change to the packman repo

zypper dup --from 5

you should remove the vlc repo as it can cause issues it comes with it’s own version of ffmpeg which is nowhere near as compleate as packman’s and the vlc versions are the same on both packman and vlc
you could also install the latest ffmpeg-4 libreries from packman
http://packman.links2linux.org/package/ffmpeg-4/873414

zypper in libavcodec58 libavdevice58 libavfilter7 libavformat58 libavresample4 libavutil56 libpostproc55 libswresample3 libswscale5 --from 5

you also seam to have the mozilla repo mixing mozilla packages might result in strange behavior so run

zypper verify

to make sure all is fine if you want to use Firefox from the mozilla repo make sure all your Firefox packages are from there

Thank you all. You gave me idea with new account, so I made it. I have a few files, so I backed it up and restore to new account. But, this thread I will be back on and will be very usefull when something like this happen.

no problems I actually use Firefox 62 from the mozilla repo but if you’re staying with 60 ESR I’d recommend removing the mozilla repo
Firefox uses the latest installed version of ffmpeg and runs fine with ffmpeg 3.4 which I believe you have but why not use ffmpeg-4 when it’s available
I’m guessing a bad shutdown or a Firefox crash damaged your profile