Firefox calling Cervisia as file manager

I am experiencing some weirdo problem since some time. I don’t use this machine often, so I cannot trace since when the problem is there.

Problem: In Firefox

Description: When a download is completed, it shows up in Downloads window. When I ask “open containing folder”, it will:

-first display a warning:

“This is not a CVS folder.
If you did not intend to use Cervisia, you can switch view modes within Konqueror.”

-will open Cervisia


And how do I perform this “switch view modes” within Konqueror?

I looked into Yast, and there is no way of removing cervisia, as it does not show up (but cervisia-kde4 does show up in the list, but it is not installed). I have no use of Cervisia, by the way.

I am on KDE 3.5, on openSUSE 11.1 x64. Firefox 3.6.

I do have an install of KDE4 on this machine, but never use it.

I followed the advice in here. First I had Nautilus as a file manager in Firefox, then some unknown one, then (following these advices) a very minimalist thing. But I still have this Cervisia critter.

The problem is likely related to KDE/Konqueror, since I tried in Gnome, and it gave me no problem (it opened Nautilus instead of Cervisia).

Any clues?

Thank you.

Right click folder - properties -
In next box click the spanner icon
In the next box - select the app you want to use to open the folder with

A bit like this

ImageBam - Fast, Free Image Hosting and Photo Sharing

apply / save

Ah, much better!

I first went into these properties options, removed the occurence of Cervisia, which was not on top anyway, and… no change. Then I looked into etc/sysconfig Editor, and found out that default displaymanager was set on kdm4, which is quite odd. Anyway I went into the KDE4 (for some reason, to access it I must select KDE - Failsafe session menu entry), and made the changes mentioned above into Konqueror and Dolphin. Then back on KDE3, it worked fine.

Thank you. The picture helped, as this icon is very very discrete!

No worries - happy to help;)

Just posting a follow up, this anomaly also occurs in OpenSuSE 11.1 KDE 3.5 after installing the “quanta” / “KDE Web Development Suite.” Doncha just love app developers who change global desktop settings w/out warning (as in, giving the user the option to pick which shell associations go with what app…)???

In this case the fix is to grep through /opt/kde3, the offending file/line is:


**change **




(assuming you want to keep cervisia as a mime type launced from firefox… )