Firefox broken-down

I am running FF 3.5.2/opensuse 11.1. Don’T know exactly when, but I made a zypper up and installed a new addon (cockiemonster) when FF began to behave strange. In the addon panel I was always told to restart FF to finish intallation, but that didn’t work. Session management by the corresponding addon didn’t work any longer. By and by I removed everything from ~/.mozilla/firefox, but FF started unimpressed, showing me my addons in the panel and telling me to finish the addon installation. He? I cleaned up the config dir, why does FF knows something about the addons I have had installed?

I tried to go back to FF 3.0, but that lead me to a dependency orgy. Zypper/Yast left my FF installation in a destroyed state. On starting FF (3.0) a tiny, empty window of about 10x10 pixels pops up, that’s all.

Any suggestions of how to recover my FF installation or how to get a working one?


You are probably better off using yast and removing firefox completely and then reinstalling.
Since you also installed your addon using zypper, it should also be listed in yast. Delete it as well.
To get firefox to start, rename the .mozilla directory to something like .mozilla.bak and start firefox from fresh.

No, I didn’t install addons with yast (I guess they aren’t available in the opensuse repos), I did it with the FF addon panel. Yes, I’ve tried that several times, reinstalling FF and removing .mozilla. But the result is liek I told you, a tiny window. Resizing this to max just shows an empty, white window…

Try renaming the .mozilla directory like I suggested and then starting firefox.

:expressionless: By any chance did you rename or remove the hidden file folder of moxilla in the home directory