Firefox broken after stupid update


After updating my system firefox doesn’t works and puts the next error in terminal: “Could not find compatible GRE between version and”

I’ve been searching/reading in forums and no solution found. Any ideas?

(removing .mozilla directory doesn’t solve my problem) :’(

Also Kaffeine change the look it has, and it is not yet my default videoplayer… is there a way to know what have i changed (log or something similar??)

My System:
Opensuse 11.1 64 bits
Kde 4.3.1 release 165

You haven’t been looking too well :wink:

When you update firefox you also need to update xulrunner to appropriate version. Make sure that xulrunner was also updated.

Also you fetched a kaffeine update from kde4 factory, you need to switch back to Packman, the kde4 version will not work.

To BenderBendingRodriguez: xulrunner is updated too. I have the mozilla repo on. I think it’s time to buy a new hdd and do some cleaning and upgrading…

ps. do you speak spanish? i’m spanish and i think i can explain better in that language…

to caf 4926: i’ve just upgraded down kaffeine and it works ok again, thanks a lot…

Hmmm, not really though i plan to learn it :wink:

So you have firefox and xulrunner installed? I propose to UNinstall both firefox and any xulrunner version 1.9.x

Then install firefox again, which should pull appropriate xulrunner version and save it somewhere on the working part of the disk :wink:

Maybe disabling the mozilla repo, and “downgrading” to the current stable version would also help?

I had that same error message when I tried the newer Firefox version, and decided to downgrade it again.

If you actually have the Mozilla repo and have priority 99 on it and the same on Updates. If Updates provides a new package then it will use it, if you let it. This should not be a problem.
See my screen](

I can’t uninstall firefox and xulrunner because yast gives me a lot of error of dependencies. (or downgrade KDE 4.3 to 4.1). Is it possible to uninstall and then reinstall in command line forgetting the dependencies? is it too risky?

I’m gonna try that growbag says, it’s simple and nice. i like this solution. hope it works :wink:

Please give us the result of this:

zypper lr -d

| Alias | Nombre | Activado | Actualizar | Prioridad | Tipo | URI | Servicio

1 | Compiz_&_XGL | Compiz & XGL | Si | Si | 99 | rpm-md | Index of /repositories/X11:/XGL/openSUSE_11.1 |
2 | Contrib | Contrib | Si | Si | 99 | rpm-md | Index of /repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1 |
3 | Emulators | Emulators | Si | Si | 99 | rpm-md | Index of /repositories/Emulators/openSUSE_11.1 |
4 | JAVA | JAVA | Si | Si | 99 | rpm-md | Index of /repositories/Java:/packages/openSUSE_11.1 |
5 | KDE_4_Community | KDE 4 Community | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop |
6 | KDE_4_Core_Packages | KDE 4 Core Packages | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
7 | mozilla | mozilla | Si | Si | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
8 | repo | NVIDIA Repository | Si | Si | 99 | rpm-md | |
9 | repo_1 | Repositorio principal (NON-OSS) | Si | Si | 99 | yast2 | Index of /distribution/11.1/repo/non-oss |
10 | repo_10 | BuildService de openSUSE - Juegos | Si | Si | 99 | rpm-md | Index of /repositories/games/openSUSE_11.1 |
11 | repo_11 | BuildService de openSUSE - Mozilla | Si | Si | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
12 | repo_12 | Repositorio Principal de Actualizaciones | Si | Si | 99 | rpm-md | Index of /update/11.1 |
13 | repo_13 | VideoLan Repository | Si | Si | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
14 | repo_14 | Packman Repository | No | Si | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
15 | repo_2 | Repositorio principal (OSS) | Si | Si | 99 | yast2 | Index of /distribution/11.1/repo/oss |
16 | repo_3 | BuildService de openSUSE - GNOME:Comunidad | Si | Si | 99 | rpm-md | Index of /repositories/GNOME:/Community/openSUSE_11.1 |
17 | repo_4 | BuildService de openSUSE - GNOME:ESTABLE | Si | Si | 99 | rpm-md | Index of /repositories/GNOME:/STABLE/openSUSE_11.1 |
18 | repo_5 | BuildService de openSUSE - KDE:Adaptaciones (backports) | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/Backports/openSUSE_11.1 |
19 | repo_6 | BuildService de openSUSE - KDE:Comunidad | Si | Si | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
20 | repo_7 | BuildService de openSUSE - Mono:Comunidad | Si | Si | 99 | rpm-md | Index of /repositories/Mono:/Community/openSUSE_11.1 |
21 | repo_8 | BuildService de openSUSE - | Si | Si | 99 | rpm-md | Index of /repositories/ |
22 | repo_9 | BuildService de openSUSE - X11:Compiz | Si | Si | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1

You have double repositories 7 & 11, get rid one of them.

Second: question, why videolan enable and packman disabled? It should be the other way :slight_smile:

Repo 18 & 18 is for KDE 3, so unless you run KDE 3 get rid of those?

Sorry, I understand every word you wrote, but I don’t understand the meaning. Can you explain a little more?

OK. There are quite some number of repo’s there. I’ll refrain from comment on that.

What happens if you go to Yast - Software Management
Filter by Repository and select mozilla
Then from the top menu select Package
In the drop box select ‘Update all in this list - Unconditionally’


UPS :sarcastic:

i didn’t realize that repo errors. I’ve playing with latest kde and i think i made a mistake. And then another one (and another one, …). I think that my system has some parts broken. As I can see that’s not a normal problem. Maybe reinstalling can be a plausible solution.

I must go out, so i cannot try the different solutions that i’m pending to do. Later i’m gonna post, I hope that it’ll work

I think your problem is xulrunner is update where as mozilla is mozilla. Rather than deleting them choose the radio button that matches so Mozilla = xulrunner from the same repo.

At the moment you have xulrunner from update and mozilla from mozilla.

You don’t really need to uninstall, there is no registry to think about :wink:

When you get rid of those repos just update unconditionally :slight_smile:

P.S. FeatherMonkey is right, he deserves a banana :slight_smile:

First of all, thanks a lot to everone who has answered.

Firefox now starts, and that’s what I’ve done to solve it (thanks FeatherMonkey):
1.- Change firefox binary from mozilla repo to updates repo.
2.- xulrunner190 from 586 to X86_64 (my system is 64 bits)
3.- put packman repo on and videolan off just like BenderBendingRodriguez told me a few lines above…

I did the three points at the same time, so i don’t know if it’s only one of them who solves my problem or two, etc…

Another question, BenderBendingRodriguez & caf4926 told me to update unconditionally, how can I do this? If I translate directly from spanish yast2 says “update if new package available” it says nothing from unconditionally. As you can imagine my system language is spanish.

FeatherMonkey you told me: “At the moment you have xulrunner from update and mozilla from mozilla”. I think that you want to said xulrunner from update and firefox from mozilla, but how knew you that? It’s amazing! thanks a lot!

Finally I’m really really sorry about my bad english.

As for how I knew by the radio button and looking at the mozilla repo. :wink:

This is one of the reasons why I’m not a big fan of update unconditionally(To do this there is an option to select all in list(Think click after select system as repo), then I think you should have update if newer))

This is why prefer zypper dup as this will/should solve these type of problems, if you have an update on update and the repos = the same priority, then it isn’t wrong it is updating to the latest. As to why the 2 repos can’t exist together I don’t know why I always thought rpm didn’t really mind this. But with zypper dup then if this happens then it will not update to the newer as for the exact choice I don’t know but it would keep the repos the same, so it wouldn’t mix the repo’s.

Edit Oh well after reading the zypper page update shouldn’t of done this, something else seems to of mixed them. Maybe an ignored dependency when going to 3.5.

Hopefully the Spanish translation will be easier to understand Zypper/Usage/11.1 - openSUSE