Firefox breaks KWin / Aurorae

https://bugzilla.opensuse.org/show_bug.cgi?id=1091592

Firefox is interfering with KWin after an update in openSUSE Tumbleweed roughly a few hours ago. All other applications (including Thunderbird) work fine, but when I startup Firefox its window has no borders whereas the titlebar appears gray. The window can also not be resized, it can only be minimized / restored by dragging it from and to the screen edges.

I’m attaching a screenshot of the broken FF window. The gray titlebar is NOT the theme I’m currently using (Aurorae), and I have no idea what skin the buttons to its upper-right are from either. KWin should not be allowing applications to have custom window managers, this might be an issue with some fundamental library.

https://i.imgur.com/CjO8JRl.png

The same here: https://forums.opensuse.org/showthread.php/530921-firefox-59-0-2-opensuse-tumbleweed

Just great. Apparently this isn’t a bug but some sort of new feature: It’s called Client Side Decorations (CSD) and it basically means that Firefox now embeds and may use its own window manager, because why not break the OS with unnecessary functionality?

First off I created a KWin window rule to force the normal titlebar to show up again. This causes two titlebars to appear, as visible in the screenshot I’m attaching here.

https://i.imgur.com/m3WCP2q.png

I next had a chat on the Firefox IRC channel about this. Folks kept saying that it should be possible to disable with browser.tabs.drawInTitlebar in about:config, but that setting doesn’t work for me and isn’t intended until Firefox 60 from what I hear. The only thing that makes it go away is running FF with the following environment variable set:

export MOZ_GTK_TITLEBAR_DECORATION=none

I’m leaving this open in case the openSUSE crew can fix it in 59 so we don’t have to wait until 60 for a solution. This clearly breaks the Firefox window for KDE users, and also looks ugly as it breaks the theme so many of us don’t want it… additionally I understand the GTK client decoration shouldn’t even be supported in version 59, so this shouldn’t even be happening at all.

Interesting. I have FF 59.0.2 64 bit from yesterday’s update, and nothing has changed. I can resize by dragging edges or corners, I have the firefox logo and thumbtack in the top left corner, the title of the tab in the center of the top bar.

dos@DOS1:~> kf5-config --version
Qt: 5.10.0
KDE Frameworks: 5.45.0
kf5-config: 1.0

Those are the versions of every component I have as well, so I wonder what the difference is. I have an AMD card and am using the amdgpu driver, if this may be relevant.

Intel Sandybridge/Ivybridge Graphics Controller.

Greetings,

I have the same issue, which is especially annoying in that I use the title bar “shade” feature so I can see every app on the desktop and typically have several firefox windows open, which breaks my daily workflow habbit…

:~$ cat /etc/os-release NAME=“openSUSE Tumbleweed”

VERSION=“20180429”

ID=“opensuse-tumbleweed”
ID_LIKE=“opensuse suse”
VERSION_ID=“20180429”
PRETTY_NAME=“openSUSE Tumbleweed”
ANSI_COLOR=“0;32”
CPE_NAME=“cpe:/opensuse:tumbleweed:20180429”
BUG_REPORT_URL=“https://bugs.opensuse.org
HOME_URL=“https://www.opensuse.org/

:~$ kf5-config --versionQt: 5.10.0
KDE Frameworks: 5.45.0
kf5-config: 1.0

:~$ firefox --version
Mozilla Firefox 59.0.2

http://susepaste.org/52209970

I just installed Firefox 59.99 / 60.0b16 from http://download.opensuse.org/repositories/mozilla:/beta/openSUSE_Tumbleweed I can confirm the issue goes away in this version and the functionality is exactly as expected: By default KWin continues acting as the window manager, and the new builtin decoration is only used if you go into about:config and set browser.tabs.drawInTitlebar to true. As long as that option remains set to false by default (especially for KDE users) there should be no more issues in the future.

My system is an Intel Kaby Lake (also graphics) and I have the same QT and KDE versions as you.

I followed MirceaKitsunes suggestion and installed Firefox 59.99. This version has no “window” problem.

Michael

[QUOTE=MirceaKitsune;2864361]… new feature: It’s called Client Side Decorations (CSD) … Firefox now embeds and may use its own window manager …

export MOZ_GTK_TITLEBAR_DECORATION=none

This feature, not merely within Firefox itself, seems to be playing havoc with Fluxbox (my preferred window manager) and IceWM. The Fluxbox popup menu is now a blank fat squat frame only: no visible menu items. If I press on the first (now invisible) item, a command box pops up, just as before. With the second one, Firefox beta is launched. Pressing Alt-T gets me a terminal emulator (as I have configured it). The popup menu is knocked out.

With IceWM, pressing on the left-hand corner pops up a menu, except that only icons are shown. That’s not the way this window manager is set up. Openbox seems immune to the Firefox’s unwarranted and unwanted meddling as far as its menu system is concerned.

I have KDE installed and updated but I normally do not use it (no GNOME for me), as colour registration is sometimes off and very hard on my eyes. I just got into KDE (Plasma). Whatever the theme is, the appearance is flat and ugly.

Whether in Plasma or a window manager, Firefox itself is now blessed with a monospace typeface with strange behaviour. There seem to be 3 spaces between words for pages for Preferences or Add-ons; bookmarks suffer from the same symptom. Arabic numerals are invisible. Preferences for Fonts do not show size, for instance. Help > About Firefox [About Firefox]: no Arabic numerals, strange spacing. No visible version information whether in stable or beta versions. I have had no problems with boxes or decorations at the top of Firefox. Otherwise, it is functional for normal browsing. I am surprised that nobody else suffers from this sudden weird malady.

And “export MOZ_GTK_TITLEBAR_DECORATION=none” does not work for me.

There’s some brief discussion of this issue on the factory mailing list…

https://lists.opensuse.org/opensuse-factory/2018-05/msg00028.html

Observed exactly the problem shown in posts #1 and #3. Closed Firefix, issued *rm -r .cache/mozilla/ *and started again, which fixed the problem.

Trying to add a bookmark in Firefox gets me a stretched-out box. Dolphin is affected, too, appearance-wise, not functionally. It’s the extra spacing or stretching out in the toolbar, among other things. Actually I cannot access the items pushed to the right off the screen. What a nuisance. Well, isn’t it a cardinal sin to whack other applications? Nobody else seems affected as I am, anyway.

Messing around within Firefox is one thing. Firefox developers should mind manners not to meddle with other applications. My system is old (the board is Rock something) but I have never experienced anything like this.

worked for me too!!!

On Fri, 04 May 2018 20:26:03 +0000, karlmistelberger wrote:

> Observed exactly the problem shown in posts #1 and #3. Closed Firefix,
> issued -rm -r .cache/mozilla/ -and started again, which fixed the
> problem.

Thank you. Clearing the cache was the step that got it to take effect
here.

Hear! Hear! Firefox seems well on the way to becoming bloated with “features”, maybe it’s time to migrate to Vivaldi.

There’s an intermittent problem with Leap 42.3 and Firefox 60.1.0esr too where the buttons on the titlebar contain black squares (but still work) and the text is obscured by an irregular whiteout in the shape of each character. The problem goes away if Firefox is restarted and “Restore Previous Session” run.

Something very similar happens if the Open Document Foundation version of LibreOffice is installed with the “KDE4 interface for LibreOffice” package (libreoffice-kde4). Not installing this package gives a less attractive window, but at least it’s usable. (Why download the ODF version? Because it works around a bug reported here Access Denied and fixed in the repository version libreoffice-6.1.)

I’ll try deleting the Mozilla cache.

DavidL.