Firefox audio icon in taskbar always showing

The icon on the Firefox taskbar entry that is supposed to only show when a tab is playing media shows all the time. Does anyone know why this might be and if I can stop it?

I’ve never paid much attention to what is displayed when playing audio from a firefox web page. Does this happen after visiting a particular website?

All I can suggest is to check the ‘browser.tabs.showAudioPlayingIcon’ property in about:config and disable it if you don’t want the notification.

You might try posting in the Mozilla forums if you don’t get the answer you’re looking for here, as this issue isn’t really openSUSE-specific.

Unlock widgets, right click the firefox widget and click remove.

Thanks. It’s either a firefox problem or a plasma problem I would guess. I’ve attached a screenshot of what I mean.

It’s supposed to show when a tab is playing audio, instead it shows all the time.

Did you try experimenting with the firefox property value I mentioned in my previous post? AFAIU it will disable the notification completely, (which might not be what you want but good as an experiment to check behaviour anyway).

Yes, and thankyou. That does disable it completely which is better than it showing all the time.

Thanks for the update.

One of your tabs should also have the audio icon.