Firefox and Wayland

Both Chrome and Firefox use XWayland

about:support in the firefox URL entry brings up a page that shows “Window Protocol: x11”

You don’t need Firefox nightly. The stable version 66.0.3 works fine with wayland. What you do need to do is set the environmental variable for it to work with wayand. You can either launch firefox with “env GDK_BACKEND=wayland firefox” or else define the variable for your system. For that, you will want to use “MOZ_ENABLE_WAYLAND=1”.

The first option gives an error and firefox doesn’t load. I tried putting export MOZ_ENABLE_WAYLAND=1 in “~/.bashrc” but that didn’t seem to change anything.

It looks like maybe you need to compile it with support.

> Do we need to use: ac_add_options --with-gl-provider=EGL if we apply this
> patch?

EGL backend is enabled by default on Wayland build so you don’t need to use this option.

I guess whatever environment that is being used to build the opensuse package is using x11.


It turns out that GNOME Classic uses x11. >_<

I switched to “regular” GNOME and now it shows “Window Protocol: wayland”

Not sure what this post may be saying is required…

I would’ve been surprised to learn that any application needed special Wayland configuration.
Firefox supposedly has shipped with Wayland support enabled since approx Nov 2018 (according to various announcements and posts).
As for a system with Wayland enabled, the following ArchWiki article describes what is required to ensure Firefox Wayland support, assuming you’re running Weston (AFAIK although Weston alternatives are being developed, they’re not widely installed), the following ArchWiki article describes a couple weston.ini files (I assume are widely distributed by default).
If there is a reason to implement Wayland as an X11 server instead of natively as a system service, the following ArchWiki and other articles describe how that might be done


I don’t think anything is required, other than your system actually using wayland. ;-]
I just didn’t realize GNOME Classic uses x11.

I removed the .bashrc entry and it still works.

hey guys, anybody aware of new way to handle wayland by firefox?
see how Ubuntu does it How to run Firefox in Ubuntu's Wayland mode (and why you should)