Firefox and kmail

Hei,

Could anyone tell me how to enable Firefox to use kmail when clicking on e-post links.

Cheers!

Simply use Google and search for “firefox+kmail” and you’ll find several how-to. May be they are not for Suse but Firefox is not distribution dependent.

Open Firefox Edit -> Preferences -> Applications. In Content Type column for mailto select kmail as Action. If KMail isn’t listed, select Use Other. KMail’s executable is in /usr/bin/.
Good luck.

Thank you both!
I have actually tried to edit firefox according to ram88 suggestion, as well as several tutorials on the net, but maybe I didn’t point to kmail’s bin file, in any case I hadn’t any luck. But I’ll have another go.

Cheers,

Olav

If the patch points to /usr/bin/kmail that should be OK. You have another problem. Is your KMail configured for an email client - can you send/receive e-mails?

F_Sauce: I did not see anywhere that you said you’re using KDE4. If you are using KDE3 then the proper command is /opt/kde3/bin/kmail

If you were using /usr/bin/kmail with KDE3 that could be why you’re not having any success.

Let us know.
socref

Hei,

Yes I can send receive e-post, no problem there . And I am using kde3.

But hey, it’s working:)

I have always used ‘about:config’ and edited my mail setup that way, e.g. as described here:Howto Setup firefox for kmail – Ubuntu Geek. I didn’t know that I could configure it within the preferences menu, but this was far easier.

Thank you all very much!

Cheers,
Olav