Firefox and Java problems...


I’m having some problems with Firefox and/or java. I’m trying desperatly to install a digital signature. This requires java. I checked through yast if I have that. It turns out I do. Half the time when I try to install this digital signature firefox crashes. The other half it forgets to aks if I want to trust content from the publisher, which is very crucial to the installation.

I try to cheat it by using Windows 7 and Google Chrome to download the signature and then movie to linux. I get an html file I’m supposed to open.

Opening this file the instructions tells me I have to press a button and/or type in a password. Except there is NO text box to type in and NO button to press.

I don’t whether its just firefox and java that just won’t work or if its the digital signature thats messed up, but somethings definatly wrong.


What might be wrong is that you’re using openjdk which openSUSE includes by default because it’s FOSS. It tends to work less reliably than Sun java especially in web based applications. You could try removing openjdk and installing Sun, it solved a problem I was having loading web based java.

# zypper rm java-1_6_0-openjdk java-1_6_0-openjdk-plugin


# zypper in java-1_6_0-sun java-1_6_0-sun-plugin

It may or may not resolve your problem, but it should eliminate any java issues.


Thanks. That code worked wonders. I had to install that digital signature before 2 pm today, else my installation code would be void. I managed to do it !! :):):slight_smile:


My symptoms were a bit different, however the change to Sun java solved my problem as well. I post it here rather than start a new thread. Thanks Raffles10 for your skill in solving this issue.

SuSE 11.2, 32 bit
586/686 processor - Athalon
Using Gnome Desktop, and official OSS java
Symptom: when visiting web sites with java applets, switching to various parts of the page would produce a warning that /etc/alternatives/…/…/java could not be executed. Type firefox -g for more information.

The extra information: Invalid Browser function table. Failed to execute applet viewer. Failed to spawn child process. Etc, etc.

Everything pointed to /etc/alternatives/…/…/java. All links were in place. Changing to Sun java solved problem. No more error messages.