firefox 89

How do I install Firefox 89?
Looked under 15.3 software and nothing there.

You can add the Mozilla repository:

There you’ll get the latest FF version.

I get no such file or directory

What exactly did you try? I’m on 15.2 so I can’t totally reproduce but I can browse that directory.

it worked fine in 15.2

Sorry, I don’t get the issue. What went wrong? (How) did you add the repo?

I tried in a terminal-didn’t work
tried in yast software adding the repository=didn’t work
I’m able to see the link you sent but everything says file does not exist?

What do you get if you try

sudo zypper ar -cfp 90 mozilla
Adding repository 'mozilla' .......................................................[done]
Repository 'mozilla' successfully added

URI         :
Enabled     : Yes
GPG Check   : Yes
Autorefresh : Yes
Priority    : 90 (raised priority)

Repository priorities in effect:                         (See 'zypper lr -P' for details)
      90 (raised priority)  :  1 repository
      99 (default priority) :  7 repositories

Well, that doesn’t look too bad. Actually, I’d now start YaST and search for the newer version of FF.

I think this should also do the job:

zypper up  --allow-vendor-change MozillaFirefox

Yes it showed up in yast now.

You’re welcome! :)Glad it works.
Have a lot of fun!