Firefox 88 seems to be broken after zypper dup today

I have

firefox --ProfileManager --no-remote

Profile manager loads, and firefox is allegedly running (ie it shows as running in “ps aux | grep firefox” but it isn’t giving me anything on screen at all

I can run firefox --Safe-Mode

and get some sort of access, but I’ve also disabled all my extensions and set the default theme, and then tried without safe mode and nothing…

Information for package MozillaFirefox:
---------------------------------------
Repository     : openSUSE-Tumbleweed-Oss
Name           : MozillaFirefox
Version        : 88.0-1.1
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 206.5 MiB
Installed      : Yes
Status         : up-to-date
Source package : MozillaFirefox-88.0-1.1.src
Summary        : Mozilla Firefox Web Browser

NB I’ve also downloaded from Mozilla the same version and installed into /opt/firefox

and have the same problem

so it’s not necessarily firefox as such, but possibly something firefox depends upon ?

Anyone else seeing this?

(posting this using chromium (Version 89.0.4389.128 (openSUSE Build) (64-bit))

I have no issues here. Same version

Name        : MozillaFirefox
Version     : 88.0
Release     : 1.1
Architecture: x86_64
Install Date: Sun 25 Apr 2021 14:58:18 BST
Group       : Productivity/Networking/Web/Browsers
Size        : 216488049
License     : MPL-2.0
Signature   : RSA/SHA256, Fri 23 Apr 2021 20:57:27 BST, Key ID b88b2fd43dbdc284
Source RPM  : MozillaFirefox-88.0-1.1.src.rpm
Build Date  : Fri 23 Apr 2021 19:04:34 BST
Build Host  : lamb76
Packager    : https://bugs.opensuse.org
Vendor      : openSUSE
URL         : http://www.mozilla.org/
Summary     : Mozilla Firefox Web Browser

 

Hi
See https://lists.opensuse.org/archives/list/factory@lists.opensuse.org/message/ARNL23XMXGEDKIE26V6TVDFKHZRRTKLY/

I wonder if it’s the switch to webrender and the system gpu…

FWIW no issues here GNOME AMD RX550 or Nvidia GT1030.

Thanks for the above replies

It seems to be related to xfce4

I’ve switched Desktop to “Gnome with Xorg” and at least Firefox loads

will investigate further

There’s a couple of bug reports regarding your issue:

https://bugzilla.opensuse.org/show_bug.cgi?id=1185267
https://bugzilla.opensuse.org/show_bug.cgi?id=1185275

Thanks

At least one of the workarounds suggested in those bug reports works

I have disabled Compositing in XFCE4 via

Settings -> Window Manager Tweaks

And FF88 now works in XCFE4