FireFox 7 - Mozzila's Aurora download

“Aurora” Mozilla FireFox 7.0a2 (2011-07-09) seems to work OK, quite a few plugins are there to, including NoScript, AdblockPlus, WoT, and HashColouredTabs+.
Haven’t got flash working, not sure why it’s not looking in the browser plugin directory :frowning:

Downloaded as result of rafter22’s post here - Firefox 5.0 ! - Page 8
Wanted to check out the de-bloating and general direction. Again (just like 4.0.1, 5.0) I find it hard to spot UI or feature changes, development is subtle progress.

$ FF=$HOME/firefox PATH=$FF:$PATH LDPATH=$FF $HOME/firefox/firefox

(firefox:18954): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

(firefox:18954): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",


The run-mozilla.sh script, I didn’t get to work right, it kept running FF5 for some reason, I trust Adobe about as far as I can throw them so I guess it’s a feature, until I want to test FlashBlock :slight_smile:
Usual probem post FF4, it’s not easy to notice what’s changed!

This seems like a windows only change Firefox 7 UI Change | Firefox Extension Guru’s Blog as we can only get the FF button with the tabs not in Window Manager area anyway.

Firefox 7 enters Aurora channel, improves memory usage - Firefox 7 enters Aurora channel, improves memory usage - TechSpot News

The issue with Oxygen-GTK icons was solved easily by downloading the 64 bit version and using that, downloaded from - Index of /pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n

I’ve found a script useful to set profile & allow running of Aurora & firefox simultaneously, mainly for tested add ons but there is a Add On Checker package which allows you to install & use them for testing purposes, then give them an all clear or not, they want a picky review of rendering and such though.

#!/bin/bash

# set -x
cd
ffdir=/usr/bin
profile=default
case $0 in
    */ffa)
        profile=Aurora
        ffdir=$HOME/firefox/Aurora
#       export LD_LIBRARY_PATH=$HOME/firefox/Aurora
    ;;
    */ffb)
        profile=Beta
        ffdir=$HOME/firefox/Beta
#       export LD_LIBRARY_PATH=$HOME/firefox/Beta
    ;;
esac
export PATH="$ffdir:$PATH"
echo `which firefox` -P $profile -no-remote "$@"
exec $ffdir/firefox -P $profile -no-remote "$@" &

Installed as ~/bin/ff with symlink ~/bin/ffa for the alpha, ~/bin/ffb the beta version. Without full path, you get XPCOM error on start. The -no-remote & profile setting lets you start the 2 versions of firefox seperately. A simple start with “-P” allows creation of new profile.

Still haven’t got Flash plugin working, it should be simple, I’d prefer using the wrapped 32 bit version for security updates, but the quick stabs at it so far have not born fruit, have tried adding like in /usr/bin to the nsplugin* programs.

ladm@fir:~> ls -l /usr/bin/nsplugin*
lrwxrwxrwx 1 root root     44 Jul  1 08:22 /usr/bin/nspluginplayer -> ../lib/nspluginwrapper/x86_64/linux/npplayer
-rwxr-xr-x 1 root root  65176 Feb 22 01:44 /usr/bin/nspluginscan
-rwxr-xr-x 1 root root 160472 Feb 22 01:44 /usr/bin/nspluginviewer
lrwxrwxrwx 1 root root     44 Jul  1 08:22 /usr/bin/nspluginwrapper -> ../lib/nspluginwrapper/x86_64/linux/npconfig

Hasn’t helped, still get prompted to “upgrade yr plugin” from Adobe :frowning:
Sure it’s something very obvious to those used to running “vanilla” firefox.

I run the stand alone profile manager and use it to start both Firefox and Thunderbird.https://developer.mozilla.org/en/Profile_Manager

I have the release and beta versions of both applications installed.

Interesting. I haven’t actually tried the stand alone profile manager knowingly, anyway.

Couple weeks on and more Add Ons are working by default. I went back to “stable” FF 5, due to 12.1 M3 pretty much. But FF7 is what should be in 12.1, with FF8 following a couple weeks later with delays for branding, build & test. Adobe put out the new 64bit plugin, still beta which I have mixed fellings about, as they were chief culprit for browser crashes in past.

Rob

You would know if you were using the stand alone Profile Manager because you have to download it, install and configure it to work with the different versions.

Call me crazy, call me dumb, call me whatever you want, but when I install openSUSE 11.4 in January when 11.3 reaches EOL, I’m going all 32-bit instead of 64-bit and will be installing Mozilla apps manually. I’ll reconsider if I see a noticeable decrease in performance.

If you have < 2GiB RAM it’s a good idea. 2 GiB plus graphics card is generally reckoned “cross over”. I used 32 bit in 10.3 with 4GiB RAM for a while and there was memory wasted because of PAE and the sizing of structures for many CPU big servers, so I switched to a non-PAE desktop kernel. They changed the kernels later for the NX bit feature of PAE, so it’s likely less of an issue now.

The 64bit Linux is better tested these days, and Mozilla are making 64 bit downloads of FireFox at least, even Adobe seem to be migrating to 64 bit support.
So rather than for real performance, I just find 64 bit runs smoother and can assume things like high resolution timers, avoiding kludges like the PAE code.

Going back to 32 bit on this box, is unthinkable, but I have couple of 32 bit boxes handly for i586 install testing anyway.