Firefox 57 - fast, but privacy?


Just tried Firefox 57 on one machine and was impressed. In both directions.

The browser is much faster now. Really.

But at the same time the installation of 57 deleted both, NoScript and uMatrix AddOns. Unbelievable. I tried to re-install them, but apparently they are not available for FF57 (yet).

So I locked Firefox on all my openSuse machines to keep 56.x as long as these crucial privacy AddOns are not available.

Just an info for all who care. No browser flames, please… :slight_smile:

ublock and umatrix are available for FF57. I have both running.
NoScript is not yet available but according to their forum the release is imminent.

But you knew that was going to happen!

At least I knew that. For the present I’m on Leap, so still using the “esr” version. So “noscript” and “flashblock” still work. When the time comes, I’m expecting to give up on “flashblock”. But noscript should be available in the new add-on format by that time.

… and I, too, am sticking to the ESR version.

Matter of fact, I have been using the ESR versions of Firefox for several years, now, for various reasons, including stability, privacy, and security.:wink:

Of course, you have to download and use the upstream version most of the time, because the ESR normally is not in the openSUSE repos. It currently is in the repos because of problems caused by Mozilla change-overs.

Just a FYI -
Tor browser and CLIQZ are two FF browsers I use often that run numerous privacy plugins,
And as of today,

Tor is using FF 52.5.0
CLIQZ is using FF 56. 0.2


Don’t. use. Cliqz.

At least if you care for privacy.

…have a look for the search term Burda. It’s German Rupert Murdoch. Don’t trust anything related to such companies.

That’s interesting, currently a concern today only for residents of Germany… still, something to watch, for those outside of Germany.
I agree that despite the ability to disable data collection which should address any “Burda” suspicions completely, it’s worrisome that just the idea of supporting data collection to target advertising is antithetical to the fundamental core of privacy.

In any case…
I run multiple browsers as a strategy to isolate my trackable activity, and my use of CLIQZ is very narrow… So even if someone tracked my use they’d see very little and a very skewed perception(might not be the same for others).


…if you don’t want Firefox 57 without the AddOns I described, lock it in YaST BEFORE you update today, as it made it’s way to the TW repo already.

If you can’t read it, enjoy the pic on the top left:

Yes, yes, a majority owner of Cliqz International GmbH is Hubert Burda Media Holding – and, Mozilla has also invested in Cliqz – and, earlier this year, Cliqz bought a (majority?) part of Ghostery Inc.

The Cliqz Browser code is MPL/GPL/LGPL – Cliqz is a commercial company, Mozilla is a commercial company, SUSE is a commercial company, Hubert Burda is a commercial company with 10 440 employees and a turnover of 2 256 billion €.

The question that needs to be asked is, what’s the difference between Firefox and Cliqz?

  • They’re both open source – and, one is a fork of the other;
  • They’re both offered at no cost by commercial companies.

[HR][/HR]And, a word with respect to privacy Add-Ons:Thanks for the list of open source Add-Ons – NoScript, uMatrix and ublock weren’t on my personal radar screen until now.

…you are pretty late then :wink:

NoScript now available, in a minimal version…

I would NOT recommend updating to FF57 and NoScript 10.

NoScript does not BLOCK any dirt by default any longer, but ALLOWS any stuff and you have to kill one-by-one. That’s not what it’S supposed to be.

Can’t edit Whitelist (effectively: EMPTY completely).

It’s a mess…

I’ve held of 57 for the moment but am watching “events”, perhaps the following is relevant?

From the NoScript support forum:

“Addon bugged out and now all scripts are running”

I have version 10.1.1 and no updates available.

Again: Don’t use this version, you are on the net without ANY protection, although it looks like at first glance. 100% fake. Unbelievable…

I have some Palemoon (not the installer, requiring root password for every update, but the zip to unpack and use directly) with “old” NoScript working as usual.

I’m seeing reports (elsewhere) that “NoScript” is now working somewhat.

I’ll stay with the “esr” version of firefox for now. Yes, I have 57 installed in Tumbleweed, but I mostly browse from Leap 42.3.

NoScript important?