firefox 3rd level keys

I actually have a problem with the keyboard config under Firefox.

I’m unable to use 3rd level keyr under firefox, in any other apps the thrird level is working.

The keayboard layout is set underkde with the setting toot.
and 3rd level set as the “super key” (win key).

the problem occur since I’ve upgrade from opensuse 11.2 to 11.3 with zypper dup (the upgrade as succes without any error) so with opensuse 11.3 KDE 4.4 firefox 3.6.6.

With a similar setting under gentoo I don’t have this problem nor with my own system base on LFS…

From there I suppose the problem come from a conflict between Suse keyboard handeling and firefox. However I don’t know where to go from there.

Any one can help?

I have the very same problem. Third level keys don’t work.

Even when I boot from the 11.3 KDE LiveCD I cannot type any 3rd level keys in Firefox. I tried changing the version of Firefox to the one in the Mozilla repo, no luck. To me the problem seems to lie with KDE though, as it works fine when I run Firefox in an IceWM session.

What is worse, I’ve had this problem before in Kubuntu 9.10.

I have no idea how to solve this however. I am just subscribing.

I did some googling and I came upon this thread here:
Third-Level-Chooser und GTK
It is in German though. The synopsis is that the user Crashtest had similar problem with his Macbook on Ubuntu wrt GTK+ apps, and after some digging solved the issue by patching the file ‘/usr/share/X11/xkb/symbols/pc’.

However, I don’t really understand how this patching works, and so I did not try it.

What I did was something far less sophisticated. I simply went and first renamed the folder ‘/usr/share/X11/xkb’ on my 11.3 install (to ‘/usr/share/X11/xkb backup’), and then moved its equivalent from my 11.2 install into its place. After logging out and logging in the 3rd level keys worked in Firefox. :slight_smile:

Then I went and undid the directory swap again, and tried similar swaps with the subdirectories of ‘/usr/share/X11/xkb/’.

I was successful swapping out ‘/usr/share/X11/xkb/rules’ from the 11.3 install with its equivalent from my 11.2 install.

And that is where I am now. The 3rd level keys work in Firefox, and I am not aware of any adverse sideeffects. However I don’t think that what I did is a particularly good solution, it is more a clumsy hack. But that is all I can do as I am at the bleeding edge of my wits. :expressionless: At least it (seems to) work for me. :slight_smile:

so the problem is coming from the xkb-dat package and GTK+… as it’s not a bug with the xkb-data package it’s a bug coming from GTK+