Firefox 3 RPM?

I see that Firefox 3 has been released and I wish to upgrade.

I downloaded the “tar.bz2” from the Firefox website and installed it using the command “./firefox” and everything seemed to work fine. Firefox 3 opened up and then when I closed it I then closed the console window too and now whenever I click on the Firefox icon I still get Firefox 2 - Firefox 3 seems to have disappeared.

I then went to Index of /pub/opensuse/repositories/mozilla:/beta/openSUSE_10.3 and downloaded the RPM for “Firefox 3.0-8.1” but it wouldn’t install as I was in dependency hell, I even tried installing “mozilla-xulrunner190-1.9.0-16.1.i586.rpm” too but it didn’t help.

Does anyone know of an official Firefox 3 RPM, preferably in the openSUSE repositories? If not, does anyone know when it will be added?

Index of /repositories/mozilla/openSUSE_10.3

~ # zypper update --type package
Refreshing 'Packman Repository'
* Cleaning repository 'Packman Repository' cache
* Building repository 'Packman Repository' cache
Refreshing 'Mozilla'
* Cleaning repository 'Mozilla' cache
* Building repository 'Mozilla' cache
* Reading repository 'Main Repository (OSS)' cache
* Reading repository 'Main Repository (NON-OSS)' cache
* Reading repository 'Packman Repository' cache
* Reading repository 'openSUSE BuildService -' cache
* Reading repository 'kde3' cache
* Reading repository 'openSUSE-10.3-Updates' cache
* Reading repository 'Mozilla' cache
* Reading installed packages [100%]

The following package is going to be upgraded:

The following NEW packages are going to be installed:
  mozilla-xulrunner190-gnomevfs mozilla-xulrunner190

Overall download size: 7.6 M. After the operation, additional 1.3 M will be used.
Continue? [yes/no]: yes
Downloading package mozilla-xulrunner190-1.9.0-1.1.i586, 6.6 M (18.4 M unpacked)
Downloading: mozilla-xulrunner190-1.9.0-1.1.i586.rpm
* Downloading [100%]
* Installing: mozilla-xulrunner190-1.9.0-1.1 [100%]
Downloading package mozilla-xulrunner190-gnomevfs-1.9.0-1.1.i586, 31.4 K (68.1 K unpacked)
Downloading: mozilla-xulrunner190-gnomevfs-1.9.0-1.1.i586.rpm
* Downloading [100%]
* Installing: mozilla-xulrunner190-gnomevfs-1.9.0-1.1 [100%]
Downloading package MozillaFirefox-3.0-1.1.i586, 924.0 K (3.1 M unpacked)
Downloading: MozillaFirefox-3.0-1.1.i586.rpm
* Downloading [100%]
* Installing: MozillaFirefox-3.0-1.1 [100%]

Thank you, adding that Repository sorted it out, thanks!

Thank you, that worked for me.

One thing to note: Firefox changed the back/forward buttons from 6 & 7 on the mouse to 8 & 9.

For me this meant changing my ButtonMapping in xorg.conf from

Option "ButtonMapping" "1 2 3 6 7 4 5 8 9"


Option "ButtonMapping" "1 2 3 8 9 6 7 4 5"

And restarting X for it to work.

There’s also a way to tell firefox to go back to using 6 & 7 here.

I D/L it to my desktop, right click/extract to/firefox3. works great.

Firefox just uses your XORG file now instead of just doing whatever it wants. Thats why.

I think there is something wrong with FF3 from the repositories. I start up one instance and 2 PID shows up, and they take 200MB+ of RAM.