Firefox 3 installation issue


I tried to install Firefox 3 using official OpenSUSE-Mozilla repository. I uninstalled Firefox 2, added the repository, and installed Firefox 3. Now, when I run Firefox on a terminal it says:

Couldn't load XPCOM.

The problem seems to be about xulrunner. When I run xulrunner directly I get this:

/usr/lib/xulrunner-1.9.0/xulrunner-bin: /usr/local/lib/ version `GCC_3.4' not found (required by /usr/lib/xulrunner-1.9.0/

I reinstalled both xulrunner 1.9 and Firefox 3 seperately. I even installed gcc 3.4.6 and redirected gcc link to gcc-3.4.6. Still no joy.

Any ideas?

(I’m using OpenSUSE 10.3 with GNOME.)

I am guessing that you are using 10.3. If so why not add the following repo to yast.

Index of /repositories/mozilla/openSUSE_10.3

Then use yast install software. This iwll then install firefox 3 and the needed extra.

Yes, I’m using OpenSUSE 10.3 (as I stated at the end). And I’m using the repository at Index of /repositories/mozilla/openSUSE_10.3 with YaST (as I stated at the beginning) :).

So, it seems like this is not a simple dependency problem.

Try this repository instead:

I had almost precisely this problem. When I attempted to upgrade to FF3 (YaST was showing a 3.0.1 version available in S/W Management), the dependency tracker added the xulrunner. But when this attempted to download, it timed out. I clicked “Skip” and it installed everything else, but then running FF3 failed as you describe.

I fixed it by going back to YaST, searching for xulrunner 1.9.0 and installing that on its own. Then everything was fine.