Firefox 3.6-64bit + java + chat room problem

I’m running OS 11.2x64, Kde 4.3, and Sun Java (latest 64-bit from the repos), and there is one chat room using the Parachat software ParaChat Site that I cannot access in the Linux version of Firefox 3.6. The chat room loads, starts, then locks up in less than a couple of minutes so tight at times I have to kill the process. (Java is usually running about 50% CPU at this point, and will shut down on its own.)

I can access the Parachat software in Windows XP (32-bit), Firefox 3.6, and latest Windows Sun Java and it works fine.

I’ve tried running Firefox with a blank “.mozilla” file, and with my normal profile, and this particular chat room is the only one that won’t work. I can get into others just fine.

Is anyone else having an issue like this one?

openjdk vs sun java be my guess, if you’ve not changed it since install. I tried the samples different distro but linux 64bit ff works fine.

I’m currently using the latest 64-bit Java from Sun. The results from using the OpenJDK were even worse with ParaChat than with the Sun Java. The chat room will load with Sun, it wouldn’t with the OpenJDK. This particular chat room is the only chat software that I’m having trouble with in Linux 64-bit. Everything works fine in Windows XP, but I’d rather not spend more time with that than I have to. :slight_smile:

Tried the ParaChat site’s evaluation chat room, and that locks up too – something I’ll pass on to their tech support. I’ve found a few other threads here in the forums that are similar, but don’t address the problem I’m having with this particular company’s chat room. Now it seems the problem may be on their end, but we’ll see.

Not sure what to say I can’t check specifically Suse as I only have a VM 32bit version but …

I’m currently working through some things with the ParaChat support folks. I’ll see what come out of that and post the results.


If anyone needs them, there are test chat rooms available on the ParaChat website, & there is a nice Java tester under the Help section also!

Backed up my .mozilla directory & wiped Firefox & Sun Java. Period. Made sure the Open Java/Ice Tea was not around either. Reinstalled FF & Sun Java from repos just to make sure any errors got wiped out, then started with a blank FF profile.

The chat room worked. It’s a little slow coming up, but it comes up and seems to work okay. Spent sever hours on it just to make sure it was stable, then started adding my extensions back in one at a time.

The extension DownThemAll was no problem, or NoScript, but AdblockPlus 1.1.3(ABP) made the browser lock up again. Something in the extension or the filters (more likely) is causing the problem, I don’t know what at this point, but I’ll keep looking into it. Keep in mind: turning off ABP does not work, only disabling or uninstalling it in the add-ons tab does.

Hope this helps someone.