Firefox 3.5.x takes huge amount of time while adding addon

When I search addons with firefox, it takes 4 mins to connect to server, and after approving to ad it, it again takes that much time to connect to download. While downloading it’s ok, but connecting to server takes time. This is for all addons. Is there any body having same issue?

Frequently disabling ipv6 helps with odd network problems…

If you’ve done that, maybe try creating a new firefox profile?

My IPv6 setting is already disabled. I’ve had this issue right after I installed opensue 11.2. So i afraid that I might loose firefox settings (like installing all the addons again) if i create a new profile. Should I try it and what’s the way for it(in windows it’s ‘firefox.exe -ProfileManager’ I think)? Thanks

You can switch between profiles - creating a new one will not delete anything.

Profile Manager - MozillaZine Knowledge Base

No, it didn’t help. When I open firefox with console there was such a writing on the console:

returned PAC proxy string: direct                                                                   
*** nss-shared-helper: Shared database disabled (set NSS_USE_SHARED_DB to enable).                  
returned PAC proxy string: direct                                                                   
returned PAC proxy string: direct                                                                   
returned PAC proxy string: direct                                                                   
returned PAC proxy string: direct                                                                   
returned PAC proxy string: direct      

I also make it “no proxy” under the connection settings, cause previous setting was use system settings. Other thing is, my firefox cannot do automatic update to itself and to addons even it’s enabled. It doesn’t let me select the options under “When updates to firefox found”

Inability for FF to update itself may well be intended behaviour - the package manager handles updates, and on a lot of distros a package’s inbuilt update systems are overridden. However, the extensions certainly should be able to update.

Sorry - no idea. You could try creating a new user to start with completely clean settings, and see if that works…?


Try deactivate proxy in configuration : select “No proxy”.
This massage desapears after this for me…

This worked for me too.

The other day I couldn’t logon (I added a script to vacuum the ff sql db and put it in kde auto start w/pre kde startup set) and I checked .xsession-errors and saw all these PAC Proxy messages. I did a:

sort .xsession-errors|uniq -cd|sort -n

and there were thousands of them. I checked this forum, found this hit, and changed the FF option and that message hasn’t appeared. I’ve been following (tail -f) the .xsession-errors file for a while. Now I just have to figure out what is causing the “file retriever error” :slight_smile:

FF performance on Linux improved greatly for me, once I started “sqlite3 *.sqlite VACUUM” but in a script. When I upgraded from OpenSUSE 10.3 to 11.2, FF was a royal pain. I bit the bullet and started with a fresh profile and added all the add-ons and changed options again. Fortunately I keep pretty good documentation. I use Asciidoc to keep the doc in text files, as well as converting to html. I kept my old FF files so I could compare. There is an addon, “Extension List Dumper” which is really nice to keep track of your addons. “Extension Manager Extended” and “Configuration Mania” are also nice.

Have you tried starting FF in safe mode. This disables extensions and themes. If ipv6 is off, maybe there is a misbehaving extension or theme.