FireFox 3.5 for openSuse

Hi all,

Is it already possible to install FireFox 3.5 ?

Thanks for your answer,



  • Add this to your repositories: Index of /repositories/mozilla/openSUSE_11.1
  • Enable and update it.
  • Once done, search for Firefox. The version that appears should be the version you already have installed. Click the checkbox to set it to update.
  • Hit accept and you should be on your way.

Thank you for the post TV-VCR. Did that today ( very easy ) and was updated to version 3.5

I do have a question related to this, don’t mean to hijack the thread. Why is it necessary to manually add a repository to have an updated version of firefox? It ships with Suse 11.1 and I noticed firefox updating my plugins from time to time. It seems like a bit of a security concern and should already be updating itself if its checking for updated plugins. I was still running the Firefox version from the first time I installed suse 11.1 few months ago ( am extremely happy with it, glad I made the switch ) .

Only reason I noticed it being out of date was when installing a new theme it pointed out I was running an older version. Did a search and stumbled on to this thread. Have 64 bit suse 11.1 installed. Would that have something to do with having to add the repo manually or is this universal ( 32 & 64 affected). Am not meaning to complain, just seems well … a bit odd.

openSUSE policy is for officially supported updates to be security/bugfix only. For example, the next version of openSUSE will include Firefox 3.5.x it will not get Firefox 3.6 as an official update, instead getting security patches for the 3.5 series.

The updating of Firefox addons is a different matter altogether. Firefox will update the addons you chose to install. Those addons are not from openSUSE nor supported by openSUSE.

Ok, now I get it. Coming from the M$ world ( Firefox would automatically popup and say “new version available” and click* it would upgrade itself) things are a little different.

Totally makes sense now. So the older version of firefox ( think it was like 3.1) was still getting the security patches, I just was running an older version. Kinda how I can run KDE 4.1, 4.2 or 4.3. I would still get updated patches, but the versions would be different.

So now that I added the Repo that TV-VCR was so kind to post and successfully updated to 3.5. I should get notifications on version updates (i.e 3.5 to 3.6 ) from the suse repo ( Index of /repositories/mozilla/openSUSE_11.1 ) as well as security patches for what ever version I am currently running from firefox.

Thank you for the clarification. :slight_smile:

Thank you for your fast reply.

But excuse my asking : how do I “Add this to your repositories: Index of /repositories/mozilla/openSUSE_11.1” ?

And where do I do it?

In YAST ? I’m fairly new to Linux, so this sounds complicated to me.

Thank you,


Maybe you can follow this simple way to add repo.

open yast-> software -> software repositories -> Add(click this button) -> community repositories (select this one) -> openSUSE build service Mozilla (check this one).

after check, click finish button to add the repo.
After this to install/update firefox open yast-> software management -> search for firefox in search box.
Select firefox and click the version tab. select the latest version which is (3.5.2) and then right click on firefox and select update. and click accept button to do the installation.

Hope, it helps.

Thank you, this worked fine.