Firefox 3.5 broken after upgrade on OpenSUSE 11.0

Don’t know if anyone can help. I’ve looked on google and found some similar symptopns for last year but no solutions.

Last week FF was working fine. The desktop upgrade applet told me there was a new version of Firefox, so I upgraded it. After that I noticed that pdf’s wouldn’t open. I’d get a tiny window, which when I expanded it had Firefox in the title bar and the rest of the screen was blank - no menu’s no mouse click, nothing.
I carried on and shut down FF at the end of the day. Today when I started, the same thing.
I tried downloading the FF 4 beta - same thing.
Tried upgrading from the mozilla repository, same thing
Tried downgrading in yast to an earlier vrsion of 3.5 - same thing
Tried downgrading to version 3.0 - same thing
Tried downgrading to 2.9 - couldn’t.

I’ve tried Opera but it doesn’t have socks proxy support. I tried chrome from yast but that doesn’t work at all.

Why can’t I just have FF working???

mmm, rather strange.

I happened to notice that there were a couple of firefox processes in the process list after all my uninstalling and installing. I killed those processes, then reinstalled 3.0 and all was well.
I was even brave enough to take the latest version 3.6.6 and it seems to be behaving normally. Go figure!