Firefox 3.5.6 Upgrade Issues

I recently upgraded Firefox from 3.5.3 to 3.5.6 and encountered the following problems:

  • Unable to open new tabs or windows from image links
  • The “recent pages” drop-down menu is always empty regardless of
    how many pages I have “flipped” through within the tab. I can still move forward and backwards though, but only blindly.

I searched for these problems on Google, but I did not find anyone else who encountered similar problems to mine.

Thank you for your help!

Not getting any of this on 32bit or _64

caf4926 wrote:
> Not getting any of this on 32bit or _64

I have mixed results:

oS 11.2 32bit, KDE4, works fine
oS 11.0 _64, KDE3.5 drop down is an empty very small box; links attached
to IMGs and mapped links work fine. No difference with safe mode.

I use the openSUSE packaged versions.


Asus m/b M2V-MX SE, AMD LE1640, 2GB, openSUSE 11.0 x86_64/XP Home VBox
Asus m/b M2NPV-VM, AMD 64X2 3800+, 2GB, openSUSE 10.3 x86_64/XP Home
dual boot
Acer Aspire 1350, AMD (M)XP2400+, 768MB, openSUSE 11.2/XP Home dual boot
Asus eeePC 4G (701), Celeron M353, 2GB, Mandriva 2009.1 on SSD/openSUSE
11.2 on USB disk

Maybe no help, just some commiseration. Consider this another report of “no recent pages”. I am using Firefox on an AMD64 box, kernel, kde 4.3.4.

Now that you mention it, I do see a microscopic speck just fractionally below and to the left of the shaded icon when I select “recent pages”. I get the same results as su root, and starting with –safe-mode.

There are a few other reports out there. Some report success by disabling various add-ons, such as flash. But so far, I am stuck too.

Next time it would be nice if people would report that stuff in (probably after searching there before).

I’m only aware of the empty dropdown since today and already isolated the issue.
As this bugfix collides with a version upgrade I’m working on it will take until beginning of January to get the fix out.

You have two options to fix the dropdown meanwhile:

  1. downgrade Firefox to the version in the official 11.2 update
    repo (as it doesn’t contain the problematic patch yet)
  2. create a new bool preference “config.lockdown.history” and
    set it to false

I’ll check if the other reported issue is related to that.


Not everyone likes the Bugzilla tho’ Wolfie, wish you guys had Mantis there :wink:

I don’t pretend that everyone likes Bugzilla. I don’t like forums and therefore missed these issues up to now. Does that help anyone?


It’s a stalemate! :slight_smile:

Not really. People here might have an issue and I could fix it if I’d know.

it’s possible