Firefox 3.0.5 Startup

openSuse 11.0, Firefox 3.0.5

If I logout with Firefox still running, next time I log in and restart Firefox, it opens all the old tabs and windows from the old session, despite being set to always start with a blank page. I have even removed the old .mozilla directory and the behaviour is the same. Is this a known issue? Is there a fix?

In KDE 4.1 goto Configure Desktop > Advanced Tab > Session Manager > On Login select " Start with empty session ".

Hi
It’s a restore feature on by default. If you open a browser window and
type about:config and search for browser.sessionstore.resume_from_crash
and double click the entry to change from true to false.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-pae
up 3:09, 1 user, load average: 0.14, 0.09, 0.09
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Thanks. I’m in openSuse 11.0, with I think a 3.5 flavour of KDE. I have found Control Centre -> Session Manager -> On login with the self same choice, but this does not address the issue. The problem is not that Firefox starts up when I login [it doesn’t until I tell it] it is what it does when it starts again.

Got it! Thanks, that looks like it will do the trick! I’ve been thinking for ages that firefox is awfully short of options.

OK, I have this set to false, firefox set to show my homepage [about:blank] when it starts up, and still it opens up all the old tabss after logging out with the firefoc session open ???

When you have a few tabs open and quit firefox - it gives you the option to close or to close and save the session. Are you doing the latter?

Neither, I don’t get the option when I logout with Firefox still running - nor if I quit normally.