Firefox 29 Downloads empty and progress not showing


Updated to the new Firefox 29 and now when I download anything, the downloads progress button is not working, the Downloads tab/folder is empty, no download progress is showing. However, the files do get downloaded and the download complete blue flash around the downloads button does pop up when the file completes downloading.

Any ideas why the Downloads is empty and no progress showing anymore? Is it a “feature” in the new version or a bug? Thank you.

Does the same problem occur in Firefox safe mode?

Troubleshoot Firefox issues using Safe Mode | Firefox Help

It was the ‘1-Click YouTube Video Downloader’ add-on! As you mentioned, I started in safe mode - everything worked fine. So I restarted in normal mode and disabled the add-on - and it started working normally.

Thank you very much for pointing out there’s a safe-mode feature in Firefox. It didn’t occur to me. Instead I tried searching in google but couldn’t find anything useful.

Still something’s wrong, wasn’t that easy.

I tried to download something today and I have the same problem - the downloads do not show in the Downloads, the button is disabled, but the files do download but there’s no way to stop/delete them. So I’ve done exactly what I’ve done yesterday, started in Safe mode, all add-ons disabled. But this time nothing’s changed, the files still download, but the Downloads is empty and there’s no way to stop them. Bizzar.

Any ideas now? Is it a OpenSuse Firefox bug? Because I do not have this problem in Windows with the same version of Firefox
Thank you.

Are you sharing the profile between the Windows and Linux versions?

I would try a new profile for the Linux version.

Use the Profile Manager to create and remove Firefox profiles | Firefox HelpIf you are using the openSUSE build I would try the Mozilla version.