Firefox 15.0 keeps crashing ...

This fixed it for me on 12.1: SDB:Firefox 15 crashes on exit - openSUSE

Seems like it’s not necessary to remove libproxy1-pacrunner-mozjs package. I just set “No proxy” in Preferences and it worked for me.

On 2012-09-04 05:26, paulparker wrote:
>
> Experiencing similar problem with Firefox 15.0 crashing regularly.
>
>
> Found a memory problem.
>
>
>>
>> linux-nnsi:~ # top -u gdm

Do not use quotes, use code tags.

Posting in Code Tags - A Guide


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I’m pretty sure it is Flash. Everytime I go to a site with Flash content, FF crashes immediately (under 12.1).

I’m pretty sure it is Flash. Everytime I go to a site with Flash content, FF crashes immediately (under 12.1).

Hmmm…I’m not experiencing that.

# rpm -qa|grep Mozilla
MozillaFirefox-translations-common-15.0-2.7.1.x86_64
MozillaFirefox-branding-openSUSE-6.1-1.1.1.x86_64
MozillaFirefox-15.0-2.7.1.x86_64
# rpm -qa |grep flash
flash-player-11.2.202.238-2.3.1.x86_64
flash-player-kde4-11.2.202.238-2.3.1.x86_64
pullin-flash-player-12.1-6.5.1.x86_64

I recognise there could be more to this story than this…

# rpm -qa | grep Mozilla
MozillaFirefox-branding-openSUSE-6.1-7.10.1.x86_64
MozillaThunderbird-15.0-33.29.1.x86_64
MozillaFirefox-15.0-2.36.1.x86_64

# rpm -qa | grep flash  
flash-player-kde4-11.2.202.233-15.1.x86_64
pullin-flash-player-12.1-9.1.x86_64
flash-player-11.2.**202.233-15**.1.x86_64
flash-player-gnome-11.2.202.233-15.1.x86_64

uuuuhhh… I just wonder if … I didn’t put a lock on Flash for some reason (well obviously because some version was worse than the one before).

Yes! I did.


# cat /etc/zypp/locks
type: package
match_type: glob
case_sensitive: on
solvable_name: flash-player*

lol!

No, it didn’t help. But starting FF with:

firefox -safe-mode

does (sites like NoMachine or ImageShack don’t crash anymore). I guess an extension is just beeing nasty. But the browser still crashes when I close it, as other people already reported.

Have you looked if your problem is similar to that?
http://lists.opensuse.org/opensuse/2012-09/msg00428.html
it mentions to remove a certain package in Wolgang Rosenauer’s answer.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.8.4 | HD 3000
eCAFE 800: oS 12.1 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

I don’t have this package. And I don’t watch Flash video either. All right, I’m getting curious now … I’m going to start with an empty profile and reinstall the (few) extensions one by one. The crashing at the end is probably another problem.

Thank you very much drhoo.
Edit > Preferences > Advanced > Network > Settings > No proxy
did the trick for me as well.

OS 12.1 64-bit Tumbleweed

I had troubles with Firefox/Flash (and KDE4) since i upgraded to 12.1. I also tried some re-installations, back to older versions and other helpless things.

I found a solution (all done with YAST, without conflicts):

  1. if flash-player and flash-player-kde4 is installed,
    replace it with the packages flash-player and flash-player-gnome.

  2. remove libproxy1-pacrunner-mozjs (and mark it with TABU in YAST).

So is my Firefox fine running. - For a crash without log entry, i think it make sense, but don’t ask me why.

Interesting.

I have both flash-player-kde4 and flash-player-gnome installed, probably because I have both KDE and Gnome installed.

I have not had any crashes.

I have no idea whether the gnome or kde or gnome version is used by firefox, though I would guess that it is using the gnome version since it is a gtk application.

And konqueror is probably using the kde version. Maybe that’s why konqueror often crashes after viewing a youtube video.

Step 1, change from kde to gnome, is only to allow Step 2 without conflicts. The solution is Step 2!

If your Firefox 15.0 is still crashing, update to the current Firefox 16.0.2.