Firefox 15.0 keeps crashing ...

Do you guys experience the same issue? It’s a new problem.

Went on the weathernetwork.com, opened a couple pages … crash.
Tried to upload a picture on Imageshack … crash.

It’s just unusable right now.

I know what you’re going to suggest … but I’m just asking before disabling the extensions one by one.
In the meantime, I’ll have to use chrome under openSUSE, I guess.

I just updated to it (along with a system update on Tumbleweed) an hour ago. I noticed a more sluggish feel when I had 10 tabs open (I could be wrong but it’s my initial impression). And in playing a Youtube video about five minutes in it suddenly restarted the video. I can’t be sure if Firefox 15 is the cause this early but I’ve read people reporting some problems, especially on Windows. 14.0.1 was rock solid stable for me. At one time I had over 125 tabs open (my work and research can get crazy) and the system ran great. I guess we’ll see in about 24-48 hours. Supposedly it should be faster for many because it’s supposed to help prevent many poorly written extensions from leaking as much memory.

On 2012-09-04 01:06, please try again wrote:
>
> Do you guys experience the same issue? It’s a new problem.

Yes, I read of it in the mail list. Some have gone back to an older version, and problem solved.
Others are trying removing some other auxiliary packages.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

I’m using FF 15.0 without issue (so far), but maybe I’ve been conservative with my extensions.

I have this issue as well. Constant crashes during normal use on a family member’s computer with Firefox. Mine (same version of opensuse and everything) does not have these issues. I think I will have to try testing a fresh profile. For now I have instructed them to use Chromium.

No problems at all here. I am using 15.0 under opensuse 12.2 RC2. I haven’t spent much time on a 12.1 system recently, so I can’t judge the stability of 15.0 there.

please try again wrote:

> Do you guys experience the same issue? It’s a new problem.
>
No issues. I tried that site too.

Only I will say that in 12.2 both Firefox and Thunderbird load very slowly (Tested on 3 differnt
computers and both 32 and 64 bit)

Experiencing similar problem with Firefox 15.0 crashing regularly.

Found a memory problem.

linux-nnsi:~ # top -u gdm

top - 10:52:54 up 3 days, 3:40, 3 users, load average: 1.00, 1.07, 1.18
Tasks: 140 total, 2 running, 137 sleeping, 0 stopped, 1 zombie
Cpu(s): 53.2%us, 0.7%sy, 0.0%ni, 46.1%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 7671468k total, 2022068k used, 5649400k free, 196736k buffers
Swap: 2104476k total, 0k used, 2104476k free, 1171836k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
22538 gdm 20 0 19388 1424 1152 R 100 0.0 1030:26 dbus-daemon
22577 gdm 20 0 0 0 0 Z 0 0.0 0:00.00 dbus-daemon <defunct>

90 minutes since restart with no problems, checking top from time to time.

On 09/04/2012 01:06 AM, please try again wrote:
>
> Do you guys experience the same issue?

this is a strange one…i’m using v15.0 with (so far) no problems on 32
bit 11.4, kde 4.6.0


dd
http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software

Suse 12.1 & FF 15.0
Crashes when closing FF.
Seems to work ok otherwise but not heavily loaded up.

jon

Yes, if it hasn’t crashed before, it finally crashes when you close it.

This happens to me too. Works flawlessly, but crashes every time I hit the close button. openSUSE 12.1 x86_64 and GNOME 3.4.1.

It’s still an improvement over Firefox 14 though, which was an absolute nightmare.

Update:

It’s actually working fairly well here after giving it a while. I’ve since had about 70 tabs open without seeing a problem. 32 bit on Tumbleweed last updated a few days ago with latest tumbleweed flash.

That happened to me when I was running openSUSE 12.1 & FF 15.0.

I just installed openSUSE 12.2, and FF 15.0 is not crashing at all, nor is it slow.

It doesn’t surprise me because I don’t seem to have this issue with other distros (i.e ArchLinux, Ubuntu and Fedora) with the same FF version (15.0) and the same extensions installed.

Worked once up until tried to close, then crash, with pop asking for feedback report, which send.

This still happens, even after in testing uninstalled mozillafirefox then deleted the entire hidden branch /home/username/.mozilla ] then rebooted then reinstalled mozillafirefox:

When start also see message (self broke the wrapping) warning :

   Could not initialize the application's security component. 
  The most likely cause is problems with files in your application's profile directory. 
  Please check that this directory has no read/write restrictions and your hard disk is 
  not full or close to full. 
  It is recommended that you exit the application and fix the problem. 
  If you continue to use this session, you might see incorrect application behaviour 
  when accessing security features.

Installed SeaMonkey so could post this !

I did I clean install of openSUSE 12.2 x86_64 from a GNOME live-CD yesterday. Guess I got fed up with the constant Firefox hiccups in 12.1, and was planing to do so anyway. The difference is remarkable, and I’m well on my way back to loving Firefox again.

Got a great first impression of 12.2 as well. I think it might be awesome :good:

openSUSE 12.1 Firefox 15 my warning at startup may have been permissions problem from OLD Firefox records in folder on desktop as since moved these to hidden partition startup has been OK.

Crashed still when exit, so far not whilst using (give it time)…

Browser used about:crashes
can see Submitted Crash reports since 6 sept 17:12

Firefox forums suggestion was the bug was in Adobe Flash and not in Firefox.

Can not tell if it’s slow but doens’t crash anymore under 12.2 indeed (at least when you close it - haven’t used it so much yet).

Haven’t observed any crashes on 11.4 KDE and 12.2 LXDE.