firefox 1-click install no longer works after upgrade to Leap 15.4

I just upgraded from 15.3 to 15.4 and as it says 1-click install no longer works.

I tried the following:

  • An unconditional install of FireFox to refresh all the files
  • Uninstall and reinstall of FireFox
  • Checking “Always open similar file types” in FireFox
  • Renaming the mineTypes.rdf file so FF would rebuild it’s associations
  • Made sure the file .y2usersettings was in my home dir.

I also just noticed it won’t go back to slack when click on “Sign In to …” in slack. Instead it just stops in the browser and I reinstalled slack just in case the dup messed it up.

I’m running out of ideas, does any have an idea of what might be going on?


Maybe it is better to refrain from using one-click install at all.

IMHO to may problems the last year, like repos added that should not be there and give major problems later (many threads here on the forums).

Perhaps but given it messed up slack as well I suspect there is something fundamental I have to fix and I’m wondering what’s the next thing that I want to click on that doesn’t work. 1-Click, slack then ??? so I need to figure this out.

Sorry, I only informed you about the very real drawbacks of the one-click install mechanism. About you special case (where you use the word “slack” that says me next to nothing), I have no idea.

You should start by providing some fundamental informations so sombody can help you. As there is no official Slack package for Leap 15.4 in normal repos:

  • which package exactly did you install (what is the exact package or program name)
  • which version
  • from where did you install
  • how did you install
  • what is the exact error or problem

I’m so concerned now. I tried magnets (torrents) and they worked so it’s not a fundamental problem with FireFox and all extension, just that the first two I tried had problems.

I was able to solve the slack problem by using the version of slack in snapd instead of the official download. Even that one wasn’t perfect but it was good enough to be able to workaround and log in and in the speil about it they noted that it was in beta and not everything is working correctly so that explains that.

Now that I know it’s just an isolated issue and not something fundamental, I can live without the the 1-click install so unless someone just happens to know what could be the issue I’m happy to just drop this and live without it.

You can search for packages online, but don’t click on any 1-click link. Instead, use the name of whatever package you searched to produce the 1-click link, then use opi with that package name to install, e.g. sudo opi slack. man opi

Was meant to be: “I’m NOT so concerned now.