finding correct path to cd-rom drive

How do i find the correct path to my cd-rom drive? I want to install office 2007 using wine and I have used the programmerfish tutorial and now have to do the following:
type wine /path to cd/setup.exe

but I cannot seem to find the correct path.

I tried /dev/sr0/setup.exe but it returned an error.
I tried /dev/sr0/media/setup.exe. returned the same error.
I tried /dev/media/setup.exe. Also no good.

I thought using df would help me and there i found /dev/sr0/ would be my cd-rom drive. Dunno it this correct though.

hope someone can help me

It’s never a path starting with /dev, that would be the hardware device. First you have to mount your CD, say by choosing to open it with Dolphin when the device notifier pops up saying a CD was inserted, and then the contents of the CD will be under /media/LABEL, where LABEL is that of the CD-ROM. So the path would be something like /media/OFFICE2007/setup.exe.

and then the contents of the CD will be under /media/LABEL, where LABEL is that of the CD-ROM. So the path would be something like /media/OFFICE2007/setup.exe.


do i have to use the cd-rom label/name (OFFICE12) too?

Yes, you have no choice in that, it’s whatever label is on the CD.

But there’s a bug in KDE where it mounts the CD with trailing spaces after the label. So you might find it’s actually something like:

/media/OFFICE2007 /setup.exe

To feed that to wine, use tab completion so that you don’t have to work out how many spaces there are:

wine /media/OFFICE<TAB>

then you will see the path to the directory something like this:

wine /media/OFFICE2007\ \ \ \ \ /

and then you can add setup.exe to it.


When I insert the Cd, Dolphin says that the cd is insert, and in ‘my computer’ I see the cd label at the drive info section.

Does this mean the drive is already mounted correctly?

To check:

Open a terminal, and do:

Look for /dev/sr0. If it’s there, the CD’s mounted

the cd-rom drive is not mounted I think, below is the outcome from ‘mount’:

corline@linux-xji9:~> mount
/dev/sda2 on / type ext4 (rw,acl,user_xattr)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda3 on /home type ext4 (rw,acl,user_xattr)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)

what to do next:

mnt /dev/sr0


When you insert the CD, your device notifier will show the CD. You can click on that to open (it will mount and open for you) using Dolphin or some other program. Open that and then try the command mentioned by Knurpht.

Also, you may follow what ken_yap has instructed, but you have to follow the above step first to make sure that CD is actually mounted.

By the by, the default wine installation does not set up MS Office properly. Why don’t you try OpenOffice?

because it’s for my sister, and I have tried openoffice for myself and it still doesn’t work 100% fine with ms word documents.

lay out and also other things are changed when opening an ms office word file in openoffice.

what do you mean by default wine installation? I read some tutorials and also installed winetricks and done the steps mentioned in the tutorials.

Not sure about winetricks, but corssover (from codeweavers) works. However, crossover is commercial.