find a pgp-key on the machine - only with the fingerprint? I need to find a certain pgp-key.

hello dear OpenSuse community,

am i able to find a pgp-key on the machine - only with the fingerprint? I need to find a certain pgp-key.

how to do that!?

In the context of this post, “fingerprint” can mean many things…

Do you mean a fingerprint reader for authentication?

If so, you’ll have to provide detail about what function requires authentication (login? website? something else?)


hello dear all - good day

well i tried some steps…:

i have tried to run the following options:

linux-jnmx:/home/martin # ssh-keygen -lf ~/.ssh/
ssh-keygen: /root/.ssh/ No such file or directory
linux-jnmx:/home/martin # $ ssh-keygen -lf ~/.ssh/
If '$' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf $
linux-jnmx:/home/martin # 

i was inspired by the following idea:

i can run the the following command to retrieve the SSH RSA fingerprint (-l means “list” instead of create a new key, -f means “filename”):

$ ssh-keygen -lf /path/to/ssh/key

So for example, on we can run a machine the command:

$ ssh-keygen -lf ~/.ssh/

Concrete example (if we use an RSA public key):

$ ssh-keygen -lf ~/.ssh/ 2048 00:11:22:33:44:55:66:77:88:99:aa:bb:cc:dd:ee:ff /Users/username/.ssh/id_rsa.p

well - as for now - i do not have the wanted solutions.

Again: i need to find a pgp - file that is somewehere on my notebook. I only have a fingerprint…

dear TSU,

many many thanks - youre right

i work with te kgpg - (the gui-programme that is delivered by the kde-group - i guess) and that programme

well i guess that the kgpg treats / handles the fingerprints / id codes in a very very special manner!?

the keys i am talking about look like something like this

or something like this : 1F308A4A

well what can we do!?

love to hear from you

hello again dear TSU.

i runned this

linux-jnmx:/home/martin # gpg -k 53875B7C
gpg: error reading key: no public key
linux-jnmx:/home/martin #

and got back - no public key…

hmmm i will continue to search…