Filter, show and replace packages by architecture?

Hi once more!

Due to my inexperience with the software management in openSUSE Tumbleweed I installed quite a few packages with the i568 architecture.

Turns out most of them can be replaced with x86_64 packages.

Is there a way to use yast to filter and show installed packages by architecture?

Or another way to find all i568 ones and bulk replace them with the referring x86_64 packages from the standard SUSE repositories?

I guess I am missing something very basic here… sorry for that.

Thx for reading,

I am not sure what you are missing here. It is IMHO a sort of miracle that you, using YaST, installed packages of the incorrect architecture at all. In any case, I doubt YaST can help you here.

I see a possibility starting from the rpm command

rpm -qa

will give you a list of all packages installed. And

rpm -qa | grep '.i568'

will give you a list of this with architecture i568. This will give you a first inventory.

Thank you!

Actually I had to install some packages from other sources. Some I couldn’t even find in the OBS - like the latest Synology Drive client for example…

(Works like a charm though I had to use alien to convert from a deb format…)

Now using your command with “rpm -qa” it turns out you are right:

After I used Yast to vendor change all dubious repository sources to use standard system packages (downgrading a few in the process, which doesn’t seem to matter at all!) all RPMs are now “x86_64” or “noarch”.

The “rpm -qa” doesn’t show any “i568” packages anymore!

I’ll add the rpm search command to my arsenal for checking regularly to make sure that I won’t mess up anymore in the future.

And I’ll use more caution…

So thanks a lot for your help!

p.s.: Is it customary to mark theredas in this forum here as “solved”?
And if so, how?

Fine it helped you to check that this aspect of your system is OK now. I doubt it is needed to check on a regular base. I guess nobody else does this. But maybe you are a bit adventurous in installing?

You said that it helped, thus this is solved. No need for extra actions.

1 Like

p.s.: I switched from an Arch system for reliability and standardized maintenance (Arch is all over the place!) so I am not yet used to the proper use of the intended or recommended use of standard SUSE, OBS and alternative sources. But I am learning… thx :slight_smile: